geforce gt 520: unable to have 2560x1440 resolution

I’ve installed debian 9 on my pc and I’m not able to have the resolution specified using the latest nvidia drivers (390.87).
I’ve tried to create a new mode with xrandr but without any luck.
Anyone have experienced and resolved this problem?

Please add

Option "ModeDebug" "true"

to the Device Section of your xorg.conf, then run as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.