GeForce GTX 1080 Ti + fresh CentOS 7.5.1804 + Dell UP3218K monitor = no graphics

Hello,

I have a fresh installation of CentOS 7.5.1804. Graphical installation was performed using a single DP cable (No graphics were possible with both DP cables attached) and the integrated nouveau drivers that ship with CentOS.

After first boot and setup, I proceeded to blacklist the nouveau drivers and install the NVIDIA proprietary drivers (396.24), and connect both DP cables from the Graphics card to the Dell 8K monitor.

-----------------------------

INSTALL NVIDIA DRIVERS

yum -y install gcc
yum -y install kernel-devel
yum -y install epel-release
yum -y install dkms

Edit /etc/default/grub. Append the following to “GRUB_CMDLINE_LINUX”

rd.driver.blacklist=nouveau nouveau.modeset=0

Generate a new grub configuration to include the above changes.

grub2-mkconfig -o /boot/grub2/grub.cfg

Edit/create /etc/modprobe.d/blacklist.conf and append:

blacklist nouveau

Backup your old initramfs and then build a new one

mv /boot/initramfs-(uname -r).img /boot/initramfs-(uname -r)-nouveau.img
dracut /boot/initramfs-(uname -r).img (uname -r)

reboot

init 3

systemctl isolate multi-user.target

sh nvidia.NVIDIA-Linux-x86_64-396.24.run

reboot

no graphics to monitor!

tried switching back and forth between graphical.target and multi-user.target with various tweaks to xorg.conf to no avail.

also ran nvidia-xconfig to no avail.

Here is my current (non functional xorg.conf):

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 396.24  (buildmeister@swio-display-x64-rhel04-13)  Thu Apr 26 01:13:52 PDT 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" 3840 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "DELL"
    ModelName      "DELL UP3218K"
    HorizSync       30.0 - 180.0
    VertRefresh     24.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "DELL"
    ModelName      "DELL UP3218K"
    HorizSync       30.0 - 180.0
    VertRefresh     24.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1080 Ti"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1080 Ti"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    SubSection     "Display"
        Depth       24
    EndSubSection
    Option         "TwinView" "1"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    SubSection     "Display"
        Depth       24
    EndSubSection
    Option         "TwinView" "1"
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

Does anyone have a functioning xorg.conf file they could share?

Thanks
nvidia-bug-report.log.gz (115 KB)

deleted

Please replace your xorg.conf with this:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:101:0:0"
    Option         "ModeDebug" "true"
EndSection

reboot and attach a new nvidia-bug-report.log

I added the following 2 lines to both Device stanzas:

BusID          "PCI:101:0:0"
Option         "ModeDebug" "true"

If you want me to completely replace my xorg.conf with ONLY the Device stanza you suggest please let me know.

nvidia-bug-report.log.gz (138 KB)

Yes, please replace it completely.

Please see attached.

nvidia-bug-report.log.gz (147 KB)

Ok, the monitor can either run 8kx4k@30Hz over one link or 2x4kx4k@60Hz over two links. The driver doesn’t know about this so detects two monitors 8k@30 so tries to run a screen of 16kx4k@30Hz which doesn’t work, obviously.
See this for the old workaround when the first 4k monitors used the same trick:
https://devtalk.nvidia.com/default/topic/982568/linux/-feature-request-proper-support-of-tiled-displays-4k-5k-etc-in-linux/post/5045023/#5045023
Though I think nvidia changed something to help with that case, if I remember, I’ll get back to you.