GeForce GTX 770M do not seem to work on pop os 22.04

Hi,

I don’t know when all broke down but someday, maybe after a update or os upgrade, my games a videos begun to lag. so i’ve search and tried many option witout real solution.
I’have a alienware that I have converted to Linux pop os some time ago.

What I did :

"sudo apt install system76-driver-nvidia "

That install driver 510 who does not suport ma card.

“sudo apt-get purge nvidia-*”
“sudo apt autoremove”

“sudo apt install-driver-470”
reboot

Nvidia card not detected anymore with
“lspci | egrep ‘VGA|3D’”

“sudo apt-get purge nvidia-*”
“sudo apt autoremove”

and now i did :
“sudo apt install-driver-470-server”
reboot

Nvidia card detected
“lspci | egrep ‘VGA|3D’”

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106M [GeForce GTX 770M] (rev a1)

“nvidia-smi”

±----------------------------------------------------------------------------+
| NVIDIA-SMI 470.129.06 Driver Version: 470.129.06 CUDA Version: 11.4 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 NVIDIA GeForce … Off | 00000000:01:00.0 N/A | N/A |
| 0% 51C P8 N/A / N/A | 89MiB / 3018MiB | N/A Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

“nvidia-settings”

(nvidia-settings:14784): GLib-GObject-CRITICAL **: 15:20:14.065: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

** (nvidia-settings:14784): CRITICAL **: 15:20:14.068: ctk_powermode_new: assertion ‘(ctrl_target != NULL) && (ctrl_target->h != NULL)’ failed

ERROR: nvidia-settings could not find the registry key file or the X server is
not accessible. This file should have been installed along with this
driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

** (nvidia-settings:14784): WARNING **: 15:20:14.124: PRIME: Failed to execute child process “/usr/bin/prime-supported” (No such file or directory)
** Message: 15:20:14.124: PRIME: is it supported? no

Bug report:
nvidia-bug-report.log.gz (362.8 KB)

I hope you have all you need to help me

Its possible your specific GPU is not fully supported by this release.

The latest driver I could find which is compatible with 770M was 418 :

I did see that in my research but this page seem to say my card was supported by 470.xx driver so i’ve stick with it :
https://download.nvidia.com/XFree86/Linux-x86_64/510.54/README/supportedchips.html

I will try it right now

i’ve tried installing the driver by nvidia-installer and register the kernel module sources with DKMS. but failed

tried again without DKMS and failed again

here the log :
nvidia-installer.log (672.3 KB)

now i do not really know how to remove all trace of this install

Driver v470 is the correct version for your gpu. Everything was working fine, please see this:
https://forums.developer.nvidia.com/t/system-doesnt-use-nvidia-gpu/215478/3?u=generix
Though I don’tt know if you broke it now.

I’ve reinstalled v470 but “sudo prime-select nvidia” does not work

sudo: prime-select: command not found

I will try a clean Install. I was trying not to do that, but to bad.

prime-select is in the package nvidia-prime. Though it might be that pop_os replaced it with their own switching method.

sorry for the late response.

You are right, Pop_op replaced it with their own utility.
Prime-select and pop os is incompatible and causes Issues.

I followed this
[Graphics Switching (Pop!_OS) - System76 Support]

sudo system76-power graphics nvidia

and now v470 work perfectly.

thanks you very much for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.