gi.overrides.Gst.AddError

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version 8.2.5.1
• NVIDIA GPU Driver Version (valid for GPU only) 470.129.06
• Issue Type( questions, new requirements, bugs) questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hello. When i run my code, it shows this error.

In jetson NX, this code is OK. I have a new computer recently,so i installed the deepstream,tensorRT and builded deepstream-python.But when i run this code, it got error.Could somebody help me?

I have another question.When i run deepstream-test1, it shows

It seems like cuda has some problems?This is my cuda info

Can you find nvstreammux?
gst-inspect-1.0 nvstreammux
Did you use deepstream SDK 6.1? if yes, please upgrade the GPU driver to 510.47 or higher. cuda 11.6

I can find nvstreammux

I’m using deepstream 6.0, so i installed 470.129 and cuda 11.4

Did you use nvidia X server?
please follow this to check
Chapter 6. Configuring X for the NVIDIA Driver

Please use TensorRT 8.0.1 for Deepstream 6.0

X server? I don’t know…i don’t use it before.
Is this problem about tensorRT version?

The problem of streammux was solved, I add streammux twice.But in jetson nx , it doesn’t show error…i don’t know why…

Now i got a new problem


and the code is

Any ideas?

ok…i soled it again…Now i got a new problem.I need push stream to rtmp, in jetson nx ,i use omxh264enc as encoder. Now i use nvv4l2h264enc, it can’t work.This is log



My pipeline can work now.But when i push stream to rtmp after a few minutes, i got error.
This is my pipeline

And this is the error

I got no ideas for this, please help me

Please add GST_DEBUG=rtmpsink:5 command to get more debug log.

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.