Issue running deepstream-app

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU): RTX 2070
• DeepStream Version: 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version: 7.2
• NVIDIA GPU Driver Version (valid for GPU only): 470.63.01

Hi,

I run into this error when I try to run the deepstream app from the sample configs (deepstream-app -c source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt). Am I missing something?

I followed all the install instructions for Ubuntu system given in the quickstart guide (Quickstart Guide — DeepStream 5.1 Release documentation)

nvbufsurftransform:cuInit failed : 100
nvbufsurftransform:cuInit failed : 100
** ERROR: <create_multi_source_bin:1320>: Failed to create element ‘src_bin_muxer’
** ERROR: <create_multi_source_bin:1411>: create_multi_source_bin failed
** ERROR: <create_pipeline:1294>: create_pipeline failed
** ERROR: main:636: Failed to create pipeline
Quitting
App run failed

How about remove the cache and run again?
rm ~/.cache/gstreamer-1.0/ -rf

Hi @amycao ,

Thanks for your reply. I tried this and got an extra warning. But still can’t get past the intial error.

Can you find these modules:
gst-inspect-1.0 nvdsgst_jpegdec
gst-inspect-1.0 nvstreammux

also can you find this file
/usr/local/cuda-11.1/lib64/libnvjpeg.so.11

Hi @amycao , I don’t have any of these. Should I try re-installing tensorrt or cuda?

Yes. you also can try with docker which have the dependency software installed.
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_docker_containers.html#a-docker-container-for-dgpu

Hi @amycao,

I’ve tried 3 different docker versions (5.0, 5.1, 6.0) and get different errors each time.

When I used deepstream 5.0, I get this error:

When I used deepstream 5.1, I get this error:

When I used deepstream 6.0, I get this error:

I make sure that my folder has all the necessary files.

I’m also using the following nvidia driver:
Driver Version: 460.91.03 CUDA Version: 11.2

I’ve attached my config files as well. Thanksdeepstream_basic.txt (1.5 KB)
model_basic.txt (767 Bytes)

For version 6.0, can you find nxstreammux?
gst-inspect-1.0 nxstreammux

Hi @amycao,

No, I can’t find this in the docker. Did I miss something?

Sorry for the wrong typo, it’s nvstreammux not nxstreammux.

Hi @amycao,

I don’t have that either.

Please try to remove the cache and run again
rm ~/.cache/gstreamer-1.0/ -rf

@amycao,

I think it’s exactly the same.

Hi @amycao,

I think I succeeded with deepstream5.1. Maybe since the nvidia driver is not the most recent one, there is some mismatch with the latest Deepstream6.0?

Also, since I’m relatively new to using dockers, I didn’t realise that I had to transfer the folders (config and data) with the configs and video file to the docker container folder.

Thanks for your help!

Which nvidia driver version you are using?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.