GPUCurrentFanSpeedRPM is 0 for EVGA GeForce GTX 1080 Ti SC2 HYBRID on Ubuntu 18.04 with nvidia-settings 418.56 and newer

I am seeing this issue specifically on the Hybrid GPU (11G-P4-6598) but not on the EVGA GeForce GTX 1080 Ti SC2 and EVGA GeForce GTX 1080 Ti SC (non Hybrid) and on “newer” 4xx.xx versions of nvidia-settings. Specifics:

m1@Miner2:~ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic m1@Miner2:~ nvidia-settings --version

nvidia-settings: version 418.56
m1@Miner2:~ nvidia-settings --terse --query [fan:1]/GPUTargetFanSpeed 50 m1@Miner2:~ nvidia-settings --terse --query [fan:1]/GPUCurrentFanSpeedRPM
0

The fans are spinning and, IIRC, this worked in previous versions. I have tried upgrading to 418.67 and the problem remains. IIRC, this worked in 396.

I can provide additional details as necessary.

I was able to install Ubuntu 16.04 along with Cuda 8 and drivers version 390. Sadly, I am still getting 0 for RPM with these cards:

m1@m1-desktop:/var/log$ sudo nvidia-settings --version

nvidia-settings: version 396.24 (buildd@lcy01-amd64-016) Wed May 2 23:28:38 UTC 2018
The NVIDIA X Server Settings tool.

This program is used to configure the NVIDIA Linux graphics driver.
For more detail, please see the nvidia-settings(1) man page.

m1@m1-desktop:/var/log$ sudo nvidia-settings --terse --query [fan:1]/GPUTargetFanSpeed
50
m1@m1-desktop:/var/log$ sudo nvidia-settings --terse --query [fan:1]/GPUCurrentFanSpeedRPM
0

So, it would appear that GPUCurrentFanSpeedRPM from nvidia-settings has never worked for this particular GPU.