HDMI audio does not work in Ubuntu 13.10 (Server)

I recently installed Ubuntu 13.10 (Server) on one of my PCs. It previously had 13.04 and a setup that worked property. I think it had NVidia 325 drivers, but I don’t remember the kernel on it. On 13.10, though, the audio does not work over HDMI.

I have verified that alsa detects the audio from the card and tried using aplay -D on each one of the (sub)devices. I get not errors, but I get no sound, either. /var/log/syslog does not contain any references to alsa.

I’ve tried NVidia drivers 304, 310, 319, and 331. I started with Ubuntu’s default kernel (3.11), 3.12.0, and 3.12.2. I get the same result no matter the combination.

However, if I load nouveau drivers the audio does work. The nouveau drivers have their own separate issues, though. I’m not sure where else to go now.

Here’s a alsa-info log: http://www.alsa-project.org/db/?f=c83932babd5197ddb61d3c806633a7fd2874b2e0

I also have a nvidia-bug-report at https://docs.google.com/file/d/0B56RmCI6UBCwcWtKZXJIVDc0OU0/edit

The video card is a ZOTAC ZT-20404-20L. The connected display is a Sony Bravia KDL32EX400.