How to setBitrate when tx2nx encode h265 yuv444?

How to setBitrate when tx2nx encode yuv444?

enc->setBitrate(1024);

It looks like that the encoder bit rate can’t be reduced.

Hi, Alfred,
1st, you should make sure your encoder is set to CBR mode,which means constant bitrate.
2nd, what is the encoding size, 1kbps obviously too small for 1080p, please set to reasonable target.

More over, you could use 01_video_encode in jetson_multimedia_api sample as your reference, it shows how to set bit rate while you are using VBR mode.

1.ret = enc->setRateControlMode(V4L2_MPEG_VIDEO_BITRATE_MODE_CBR);
2.I just test. But the bitrate can’t be reduced.
ret = enc->setBitrate(1024 * 1024 * 10);
whatever the rate is 1024 or else. It’s still keeping about 1 MB per frame. That means 60 MB per second.

Could you reproduce this issue using our 01_video_encode example?

My input data is mipi RGB888, how to use 01_video_encode?

Hi,
Encoding YUV444 data into h265 stream is lossless mode, so bitrate cannot be changed.

It’s about 60MB per second.
If I use YUV444 H265, the bit rate is static, It can’t be transmited by the network.
Any suggestion?

Hi,
If you need rate control, please encode YUV420 frame data. It is a general use-case and there are properties for setting/controlling bitrate.

@DaneLLL
My project needs YUV444 and transmits on the network.
YUV444 H265 has no rate control that menas hardware is not supported or the hardware is supported but the sdk is debugging? Will it support in the future?

Hi,
We are checking your request. Check if we are able to support this in future release.

On Jetpack 4.6(r32.6.1), the implemented and verified case is lossless encoding.