How to use Opencv alongside with CUDA?/ Eclipse IDE as a text editor

Good morning, I have completed most of the requirements to begin using Jetson as a developer platform.

But there are some things that I still don’t know how to handle.

One of them is that I want to use Opencv with CUDA for coding image processing algorithms.

Is there any documents or tutorials that teaches you how to do it step-by-step right within the TK1? This is because I have tried to run the example codes at Opencv github but they just don’t run. I believe this is a path problem.

Also, I have another question…

I want to use Eclipse IDE as my text editor for coding ( vim or emacs are options that i would prefer to avoid). It is posible to download and use it on my Jetson? If I can use Nsight along with them, it will be better.

Thank you for reading.

Just a thought on the topic…unless you want CUDA integration and need the nsight edition of eclipse you have several choices. One editor I know works on a TK1 and is perhaps a bit smaller in footprint is “juffed”. “sudo apt-get install juffed” should work, though I have all the repos enabled so I don’t know if juffed is there on the default repo list.

I tried to install eclipse in two ways: by a packaged downloaded from another computer and with terminal typing “sudo apt-get install eclipse”.

In both ways it keeps telling me the same thing:

bash: ./eclipse:cannot excecute binary file: incorrect executable format

After a little research on google, I believe this is a problem due to the diferent CPU architectures. While normally eclipse will run on 32/64 bits kernels, maybe the ARM architecture is unsupported.

I’m giving up trying to use Eclipse on jetson. I shall try juffed. Thank you for the answer.

For TK1, I think you should look for a armhf architecture package.
What gives

sudo apt search eclipse

on your TK1?

It seems it’s available here at least:

You can’t use a desktop architecture version on arm64, this is why you see “cannot excecute binary file: incorrect executable format”. Looks like you got a standard PC format when you tried it on the Jetson.

If you have the right repository enabled, you should be able to:

sudo apt-get install eclipse

…should that not find eclipse, it simply means you need another repository enabled. There are some commented out in “/etc/apt/sources.list” which could be enabled if this is the case, then “sudo apt update” would allow eclipse to be seen. If eclipse does not show up, then it is possible juffed also would not show up…in which case you’d uncomment the repos in that sources.list for this case as well.

Hello, sorry for my inactivity.

Here is what I got from searching eclipse, the most relevant ones:

eclipse/trusty 3.8.1-5.1 all
Extensible tool platform and java IDE

eclipse-cdt-jni trusty now 8.3.0-1 armhf
C/C++ Development Tools for Eclipse (JNI)

I tried to install those packages but it didn’t work either.

I guess I should just use a good text editor.

Thank you Honey_Patouceul and linux_dev for the help.