HPE DL 280 with A16 - Bare metal setup not working

We have a standalone, bare metal server (HPE DL 280 w/ A16) that we would like to use for 3D workloads under RDS. We have completed the nVidia licensing process (created a DLS, registered with the license portal, generated a client token).

One the server we have

  • installed the latest A16-supplied driver:
    Data Center Driver For Windows
    Version: 528.89 WHQL
    Release Date: 2023.3.30

  • Configured the registry per the documentation for physical devices:
    FeatureType = 0x00000000

  • Copied the client token to the correct directory:
    %SystemDrive%:\Program Files\NVIDIA Corporation\vGPU Licensing\ClientConfigToken

The nVidia control panel lists only ‘Developer’ options and acceleration doesn’t appear to be working properly given the tests that we’ve run. The A16 card(s) are listed properly in the device manager and are accessible in GPU-Z.

What are we missing?

Upon further reading, the documentation states:

In a bare-metal deployment, you can use NVIDIA vGPU software graphics drivers with vWS and vApps licenses to deliver remote virtual desktops and applications. If you intend to use Tesla boards without a hypervisor for this purpose, use NVIDIA vGPU software graphics drivers, not other NVIDIA drivers.

However, I do not see a standalone vGPU driver in the SOFTWARE DOWNLOADS section. I attempted to use the Hyper-V “Complete DDA GPU driver package for Microsoft platforms”, but the 64-bit Windows 2019 server driver reports that it doesn’t detect any cards.

Is there a different driver that I should be installing?


You did the right thing. Guest driver is the same in all the packages. This driver should definetely recognize A16 GPU
Coul you elaborate which driver you tried?
I would recommend to use LTSB release 13.8.

In the nvidia Licensing Portal, I selected Software Downloads which presents ~115 pages of packages.

I chose the latest Microsoft Hyper-V:

Microsoft Hyper-V Server
Complete DDA GPU driver package for Microsoft platforms
Jun 26, 2023

That package contains the driver installer:


When I run that package, it reports no card found. I don’t see a standalone vGPU driver package after scrolling through the entire collection of packages. I don’t recall seeing any packages marked with ‘LTSB’.

vGPU 11.x cannot work!
Please use the current vGPU 13.8 package as stated above.
BTW: a current release date doesn’t mean it is the newesg version but this branch got a minor update if it is also a LTSB brach which we support for at least 3 years.

Please see NVIDIA Virtual GPU (vGPU) Software Documentatio to get more infos on our release cadence…