I can't find this menu “Visual Scripting” on isaac sim

I saw in this link that I need to click Window > Visual Scripting > Action Graph to open the Action Graph window, but my Isaac sim SDK does not have this option. Can you help me?
WeChat 圖片_20220608103338

By the way, my Isaac sim SDK version is 2021.2.1 and my system version is ubuntu 18.04.6 LTS

Hi @user2373,

I would try loading an example from Isaac Examples which is contained in the toolbar. Some of these examples already have action graphs associated with them (e.g. MoveIt example does). Hopefully having done this the option to display an action graph window will appear for you under Window > Visual Scripting > Action Graph. It does for me.

You can also generate action graphs under the create tab if you are building your own. If you start to create one I believe the option to display this will be available under the window tab as well.

Hopefully this helps resolve your issue.

Hi @peterdavidfagan,
I try to open the Kaya Gamepad example: go to the top Menu Bar and Click Isaac Examples > Input Devices > Kaya Gamepad, and press the LOAD button to load a Kaya robot into the scene. But there is not Visual Scripting option on the Windows Menu.
How can I get the Visual Scripting menu?

Hi @user2373,

I have the visual scripting option under the window dropdown in my installation when I open up the Kaya Gamepad example. I think this is because I have opened the Action Graph window previously.

Have you tried creating an Action Graph (Create > Visual Scripting > Action Graph)? I am sure this should be an option and it will indirectly open the tab for Action Graph. After doing this maybe the option will show under the window tab?

Hi @peterdavidfagan
I can’t find the visual scripting option under any tab, I think it might be the reason for my Isaac sim SDK,
Thank you!

Hi @user2373,

I didn’t think of this earlier but maybe you need to activate the extension for action graphs?

" 1. Ensure that the following extension bundle is loaded: omni.graph.bundle.action"


Hi @user2373

I had same problem too and i solved it by updating my isaac sim 2021.2.1 to 2022.1.0

I hope it help you too.

1 Like

Hi @alperen708
Thanks for your answer!The problem is solved!!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.