I have windows 2012R2 OS on Dell R710.When i connect mellanox nics and cables through a Dell switch with 40G ports, It shows network cable unplugged.

I have windows 2012R2 OS on Dell R710.When i connect mellanox nics and cables through a Dell switch with 40G ports, It shows network cable unplugged.

Hi,

Could you follow this post?

Can you describe more about your performance issues?

What is the connectivity of your setup?

Dell Storage with Microsoft Storage Spaces (DSMS) - Networking Quick Reference https://community.mellanox.com/s/article/dell-storage-with-microsoft-storage-spaces--dsms----networking-quick-reference

Ophir.

If you’re running things in Infiniband mode, is there a subnet manager running on the network?

This kind of sounds like what happens when you run without a subnet manager. If you’re not sure, try running the OpenSM service and see if the network cables suddenly start showing up as connected.

He is saying Dell switch, I don’t think that it is InfiniBand.

Few questions:

Did you install WinOF driver?

Could you make sure that the port is configured with Ethernet (if this is the case)?

Try to replace cable or switch port to make sure that there is no problem with the HW.

Thanks,

Ophir.

First, I would make sure you are using supported adapters, cables, and SFPs for both the Mellanox cards and the Dell switch. There are known issues when mixing certain types of SFPs and cables, and with certain kinds of Twinax.

If all the hardware is supported, please make sure the WinOF driver is installed and that the Mellanox port is configured to Ethernet (for VPI adapters).

I would then try directly connecting the NICs to eachother to bypass the Dell switch. Try running some IO using direct connect to verify your cards and cables are working. If this works → either a compatibility issue with SFPs/cables and Dell switch, or the switch is configured incorrectly.

Thanks guys,Im able to get access to nics now. But the performance is not up to the mark.

Should I do any changes on the nic parameters, as of now i have kept the default settings. Im using windows 2012 R2 server.