ImportError: /usr/lib/aarch64-linux-gnu/ file too short error

Hi! Im am trying to deploy my python app to Jetson Nano 2gb with docker. Firstly I solved problem with upgraded docker issue by following instructions from this topic:

after downgrading docker, building new image and running a new container with this command:

sudo docker run --runtime nvidia -it \
    --name=7food-fridge \
    --restart=always \
    --network host -e DISPLAY=$DISPLAY \
    -v /tmp/.X11-unix/:/tmp/.X11-unix \
    -v /tmp/argus_socket:/tmp/argus_socket \
    -v /etc/enctune.conf:/etc/enctune.conf \
    -v /etc/udev/rules.d:/etc/udev/rules.d \
    -v /dev:/dev \
    -v /sys/class/gpio:/sys/class/gpio \
    -v /sys/devices:/sys/devices \
    -v /dev/gpiochip0:/dev/gpiochip0 \
    -v /dev/gpiochip1:/dev/gpiochip \

app raise error like that:

Traceback (most recent call last):
  File "src/", line 8, in <module>
    import modules.detection as detection
  File "/usr/scr/app/src/modules/", line 2, in <module>
    import jetson.inference
  File "/usr/lib/python3.6/dist-packages/jetson/inference/", line 8, in <module>
    from jetson_inference_python import *
ImportError: /usr/lib/aarch64-linux-gnu/ file too short

I tried add “default-runtime”: “nvidia” to /etc/docker/daemon.json, rebuild image and reboot machine, but that didn’t work. Also app works fine without docker.
My docker image based on dustynv/jetson-inference:r32.5.0


May I know which JetPack version do you use first?
Do you also set up Nano with the JetPack 4.5.1?


I forgot to change dustynv/jetson-inference:r32.5.0 to dustynv/jetson-inference:r32.6.1 after updating JetPack. Thanks for pointing me in the right direction!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.