IMX219-160 8MP Camera Module --- No available

The IMX219-160 8MP camera on my hand works fine with B01 carrier board and P3448.
When I used a 3rd party carrier board + P3448, the system can not recognized the camera.

I run v4l2-ctl --list-devices , and no camera devices found.
I checked the I2C bus, no signals when I run camera command.

I am assuming the system recognized the camera device by I2C communication, I am right?

On B01 carrier board, camera I2Cs are divided by 1:2 Mux. And on the 3rd party carrier board camera I2C are directly connected to the pin 213/215 of the P3448 core board connector.

Would this hardware difference affect the I2C communication?

Thanks a lot~

Hi @zheng1 !

For Jetson board related questions I recommend to talk to the experts in that category.

I took the liberty of adjusting the category of your post and added the Jetson tag as well.


There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

hello zheng1,

since you’re working with 3rd party carrier board,
could you please confirm all the configuration file were correctly flashed.
please also examine the device tree blob, do you also revise the hardware connections accordingly?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.