Input video from USB capturing device (core dump in video-viewer/detectnet)


I have a USB capturing device to feed an HDMI signal to the USB and act as a webcam signal.

I can use this device in my Window computer. However, when I use this device for video-viewer program, there is a core dump,
GStreamer-CRITICAL **: 10:29:41.859: gst_element_message_full_with_details: assertion ‘GST_IS_ELEMENT (element)’ failed
The display popup for 1 second and then core dump occur…

Here is the info of the USB capturing device. it use MJPEG, and I have tried --input-codec=mjpeg with --input-width=640 – input-height=480 and others, no help though…

Here are the capture screen when I run detectnet.

Plan B: Is there HDMI capturing device that can be used in Jetson? Thx

By default it supports USB cameras outputting YUV422 format, such as UYVY, YUYV. If your camera supports only MJPEG, you would need to customize the sample app. Please try to run the camera in gst-launch-1.0 command, and then apply the same pipeline to the sample app.

I have struggled to get it working for a week, no luck…
Is there any cheap HDMI capture device that can do that? Thx

Hi @AK51, if you run video-viewer /dev/video3 do you see any video?

Are you able to view the stream with other V4L2 viewer tools like cheese, gst-launch, ect?

Also from your terminal output, it appears you are using an older version of jetson-inference - can you try cloning the latest from the repo and rebuilding/reinstalling it?

If you’re not able to see the camera feed with any tool, please provide the output of:

# -d3 will report about device node /dev/video3
v4l2-ctl -d3 --list-formats-all

so that you can first try to set up a valid gstreamer pipeline to decoded video with gst-launch-1.0.
Once you will have this working, then patching jetson-utils/gstCamera for your case may be easy.

Hi ,I got the detectnet work on my hdmi capture box, however, it only last for couple mins and then core dump. :<
(The detectnet works perfectly for c270 camera though) I suspect it is the problem with the hdmi signal from the capture box. How can I debug it…?
I have tried these but all have core dump…
detectnet /dev/video1
detectnet --input-width = 1280 --input-height = 720 /dev/video1
detectnet --input-width = 1280 --input-height = 720 – input-codec=mjpeg /dev/video1
detectnet v4l2///dev/video1

It seems ok now. I have tested for 30 mins.
I have to connect a monitor to the output of my capture box. I guess it keeps the hdmi signal stable?
Anyway, it works. :> Thanks

OK thanks for letting us know, glad you got it working @AK51.

Here is the working setup. Lots of wires though. (I have tired a RCA to HDMI adapter but it doesn’t work)
Anyway, thanks for the help and moral support. Cheers