Live camera detection help

Hello! just got my jetson nano and have run into a problem I cant figure out. I’m currently following the tutorials and when I cam across to the live camera detection section I get an error, I’ll paste it below:

  args (2):  0 [./detectnet-camera]  1 [facenet]  

[gstreamer] initialized gstreamer, version
[gstreamer] gstCamera attempting to initialize with GST_SOURCE_NVCAMERA
[gstreamer] gstCamera pipeline string:
nvcamerasrc fpsRange="30.0 30.0" ! video/x-raw(memory:NVMM), width=(int)1280, height=(int)720, format=(string)NV12 ! nvvidconv flip-method=2 ! video/x-raw ! appsink name=mysink
[gstreamer] gstCamera failed to create pipeline
[gstreamer]    (no element "nvcamerasrc")
[gstreamer] failed to init gstCamera (GST_SOURCE_NVCAMERA)
[gstreamer] gstCamera attempting to initialize with GST_SOURCE_NVARGUS
[gstreamer] gstCamera pipeline string:
nvarguscamerasrc ! video/x-raw(memory:NVMM), width=(int)1280, height=(int)720, framerate=30/1, format=(string)NV12 ! nvvidconv flip-method=2 ! video/x-raw ! appsink name=mysink
[gstreamer] gstCamera successfully initialized with GST_SOURCE_NVARGUS

detectnet-camera:  successfully initialized video device
    width:  1280
   height:  720
    depth:  12 (bpp)
detectnet-camera:  camera open for streaming
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:532 Failed to create CaptureSession

detectnet-camera:  failed to capture frame
detectnet-camera:  failed to convert from NV12 to RGBA
detectNet::Detect( 0x(nil), 1280, 720 ) -> invalid parameters
[cuda]   cudaNormalizeRGBA((float4*)imgRGBA, make_float2(0.0f, 255.0f), (float4*)imgRGBA, make_float2(0.0f, 1.0f), camera->GetWidth(), camera->GetHeight())
[cuda]      invalid device pointer (error 17) (hex 0x11)
[cuda]      /home/jetbot/Desktop/inference/jetson-inference/detectnet-camera/detectnet-camera.cpp:247
[cuda]   registered 14745600 byte openGL texture for interop access (1280x720)

On previous chapters the onboard camera works fine, but as soon as I try something with video it causes this error.The first block I pasted above says that the camera is initialized… Then the next block says it cant use it :/

Hi James Carter, if you were able to run the previous camera example (imagenet-camera), then in theory it should be working here too because the camera code is the same.

Does detectnet-camera work for you after a reboot? Are you able to view the video with nvgstcapture-1.0 application?

If you continue to experience the issue, can you post dmesg log after attempting to run detectnet-camera program?

@dusty_nv That’s the one thing I had not tried yet… It worked! Thanks!