Install nvidia container runtime with docker intergration in jetson nano emmc (16gb)

Hi, Thank for nvidia-sdk-manager, we can flash our jetson nano emmc and install nvidia-docker manually (due to the limited storage).

sudo apt install nvidia-docker2
Update docker daemon
sudo vim /etc/docker/daemon.json
Ensure that /etc/docker/daemon.json with the path to nvidia-container-runtime:

{
    "runtimes": {
        "nvidia": {
            "path": "/usr/bin/nvidia-container-runtime",
            "runtimeArgs": []
        }
    }
}
Make docker update the path:
sudo pkill -SIGHUP dockerd

Howerver, unlike jetson sd, we had some problems installing some libraries that needed cuda.

libcublas.so.10.2: cannot open shared object file: No such file or directory

I checked, there is size difference of folder cuda-10.2 between docker container emmc and sd
In container emmc: /usr/local/cuda-10.2 – 111mb
In container sd: /usr/local/cuda-10.2 – 2.6gb

Step to install cuda in emmc

sudo apt install cuda-toolkit-10.2
export PATH=/usr/local/cuda-10.2/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-10.2/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} 

Step to run docker container:

nvidia-docker run -it -d --runtime nvidia --restart=always  --net=host nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples

Therefore, I think this is an issue related to the nvidia runtime of the container. Look forward to the help.

Hi,

Have you tried to launch it with docker directly?

For example:

$sudo docker run -it --rm --net=host --runtime nvidia ... 

Thanks.

Hi @AastaLLL Thank for your response.

nvidia-docker run -it --runtime nvidia --restart=always --name fr_prod --net=host nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples
root@wesmart-desktop:/opt/nvidia/deepstream/deepstream-5.1# du -sh /usr/local/cuda
0	/usr/local/cuda
root@wesmart-desktop:/opt/nvidia/deepstream/deepstream-5.1# du -sh /usr/local/cuda-10.2/
111M	/usr/local/cuda-10.2/

The result is still the same

Hi,

Which JetPack do you use?

Since Deepstream 5.1 depends on the JetPack 4.5.1 which is released for a while.
If you are using a newer JetPack version, could you upgrade to the corresponding Deepstream instead?

Thanks.

Hi @AastaLLL Sorry for my lack of information.
Jetson nano Emmc 16gb (4gb ram).

Hi,

Deepstream 5.1 is released for a while.
Would you mind upgrading your environment to Deepstream 6.0 + JetPack 4.6.1 and giving it a try?

The file size looks good within the deepstream-l4t:6.0.1-base container:

$ sudo docker run -it --rm --net=host --runtime nvidia  -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.0 -v /tmp/.X11-unix/:/tmp/.X11-unix nvcr.io/nvidia/deepstream-l4t:6.0.1-base
$ du -s -h /usr/local/cuda-10.2/
2.9G    /usr/local/cuda-10.2/

Thanks.

Hi, Thank for your information.
It is considered a bug of ds5.1, if possible, we will plan to upgrade our project to 6.0.1/6.1.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.