Installing Mellanox OFED 4.5- on ARM CentOS 7.6.1810 (AltArch)

I’ve upgraded the operantig system of my ARM server with a ConnectX-5 adapter from Centos 7.5 to Centos 7.6. So, I need to upgrade the Mellanox OFED stack too. I’ve downloaded it, then I tried to install it with the “./mlnxofedinstall --add-kernel-support” command, but it fails with the message:

Failed to build mlnx-ofa_kernel 4.5 RPM

Taking a look to the mlnx-ofa_kernel-4.5.rpmbuild log file, there is a “36767 Bus error” during the compilation, so the whole process ends a few seconds after it. I can’t understand the reason… anybody can help me?

mlnx-ofa_kernel-4.5.rpmbuild.log (412 KB)

general.log (18.3 KB)

Hi Marco,

I suggest to review the release notes of MLNX_OFED 4.5 and check which OS is supported with ARM server :

In addition, Does this setup worked before with older CentOS and OFED versions?



Hello Samer, it’s true that the release notes of MLNX_OFED 4.5 mention RHEL7.6 ALT but not CentOS 7.6 ALT; nevertheless it was the same for MLNX_OFED 4.4 and CentOS 7.5 ALT, but in that case we were able to compile the “kernel support” without any problem.

Hi Marco,

MLNX_OFED 4.5 is a different driver .

We always suggest to use the supported and tested OS’s with Mellanox OFED driver.


Sometimes it can work as you mentioned.

But since it’s not supported/tested we cannot guarantee functionality as on this case.