mlnx-en-4.2-1.0.1.0-rhel7.2-x86_64 with latest centos kernel 4.14.14-1.el7.elrepo.x86_64

Hi,

i am trying to install mlnx-en-4.2-1.0.1.0-rhel7.2-x86_64 with latest centos kernel 4.14.14-1.el7.elrepo.x86_64. But i get below errors.

I had centos 7.2 with 3.10 kernel and upgraded the kernel to latest mainline kernel 4.14. i have taken care to update kernel-ml-headers & kernel-ml-devel.

Note:

I am able to install mlnx-en-4.2 on 3.10.0-123.9.3.el7.x86_64 kernel without any issue.

The system has connectx3-pro nics.

[root@localhost mlnx-en-4.2-1.0.1.0-rhel7.2-x86_64]# ./install --without-fw-update --force --kernel 4.14.14-1.el7.elrepo.x86_64 --add-kernel-support

Note: This program will create mlnx-en TGZ for rhel7.2 under /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64 directory.

See log file /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/mlnx_ofed_iso.9424.log

Checking if all needed packages are installed…

Building mlnx-en RPMS . Please wait…

ERROR: Failed executing “MLNX_OFED_SRC-4.2-1.0.1.0/install.pl --tmpdir /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64 --kernel-only --kernel 4.14.14-1.el7.elrepo.x86_64 --kernel-sources /lib/modules/4.14.14-1.el7.elrepo.x86_64/build --builddir /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/mlnx_iso.9424 --disable-kmp --force --build-only --distro rhel7.2”

ERROR: See /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/mlnx_ofed_iso.9424.log

Failed to build mlnx-en for 4.14.14-1.el7.elrepo.x86_64

LOGS:

Logs dir: /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/OFED.9558.logs

General log file: /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/OFED.9558.logs/general.log

^[[32m

Below is the list of OFED packages that you have chosen

^M(some may have been added by the installer due to package dependencies):

^[[0m

mlnx-ofa_kernel

mlnx-ofa_kernel-modules

This program will install the OFED package on your machine.

Note that all other Mellanox, OEM, OFED, RDMA or Distribution IB packages will be removed.

Those packages are removed due to conflicts with OFED, do not reinstall them.

Build mlnx-ofa_kernel 4.2 RPM

Running rpmbuild --rebuild --define ‘_topdir /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/mlnx_iso.9424/OFED_topdir’ --define ‘_sourcedir %{_topdir}/SOURCES’ --define ‘_specdir %{_topdir}/SPECS’ --define ‘_srcrpmdir %{_topdir}/SRPMS’ --define ‘_rpmdir %{_topdir}/RPMS’ --nodeps --define ‘_dist .rhel7u2’ --define ‘configure_options --with-core-mod --with-user_mad-mod --with-user_access-mod --with-addr_trans-mod --with-mlxfw-mod --with-mlx4-mod --with-mlx4_en-mod --with-mlx5-mod --with-ipoib-mod --with-innova-flex --with-innova-ipsec --with-srp-mod --with-iser-mod --with-isert-mod’ --define ‘KVERSION 4.14.14-1.el7.elrepo.x86_64’ --define ‘K_SRC /lib/modules/4.14.14-1.el7.elrepo.x86_64/build’ --define ‘_prefix /usr’ /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/mlnx_iso.9424/MLNX_OFED_SRC-4.2-1.0.1.0/SRPMS/mlnx-ofa_kernel-4.2-OFED.4.2.1.0.1.1.g75959ea.src.rpm

^[[31mFailed to build mlnx-ofa_kernel 4.2 RPM^[[0m

Collecting debug info…

^[[31mSee /tmp/mlnx-en-4.2-1.0.1.0-4.14.14-1.el7.elrepo.x86_64/OFED.9558.logs/mlnx-ofa_kernel-4.2.rpmbuild.log^[[0m

Hi,

This kernel is not yet supported by MOFED 4.2

The MOFED 4.3 will support kernel 4.14 and is planned for end of February.

You can use the inbox driver for now.

BR

Marc