MLNX_OFED install failed at Ubuntu 18.04.2


I am trying to install MLNX_OFED but failed.


# uname -a

Linux edci-rdma-server 5.3.0-51-generic #44~18.04.2-Ubuntu SMP Thu Apr 23 14:27:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Below are the messages I got from the terminal.

# ./mlnxofedinstall --add-kernel-support --with-nvmf

Note: This program will create MLNX_OFED_LINUX TGZ for ubuntu18.04 under /tmp/MLNX_OFED_LINUX-5.0- directory.

See log file /tmp/MLNX_OFED_LINUX-5.0-

Checking if all needed packages are installed…

Building MLNX_OFED_LINUX DEBS . Please wait…

ERROR: Failed executing "MLNX_OFED_SRC-5.0- –tmpdir /tmp/MLNX_OFED_LINUX-5.0- --kernel-only --kernel 5.3.0-51-generic --kernel-sources /lib/modules/5.3.0-51-generic/build --builddir /tmp/MLNX_OFED_LINUX-5.0- --without-dkms --without-debug-symbols --build-only --distro ubuntu18.04"


Failed to build MLNX_OFED_LINUX for 5.3.0-51-generic

And here is the content of log file( /tmp/MLNX_OFED_LINUX-5.0-

# cat /tmp/MLNX_OFED_LINUX-5.0-

Logs dir: /tmp/MLNX_OFED_LINUX-5.0-

General log file: /tmp/MLNX_OFED_LINUX-5.0-

Below is the list of OFED packages that you have chosen

(some may have been added by the installer due to package dependencies):












Checking SW Requirements…

One or more required packages for installing OFED-internal are missing.

Attempting to install the following missing packages:

bzip2 debhelper dh-autoreconf quilt gcc pkg-config build-essential make

This program will install the OFED package on your machine.

Note that all other Mellanox, OEM, OFED, RDMA or Distribution IB packages will be removed.

Those packages are removed due to conflicts with OFED, do not reinstall them.

Installing new packages

Building DEB for ofed-scripts-5.0 (ofed-scripts)…

Running /usr/bin/dpkg-buildpackage -us -uc

Building DEB for mlnx-ofed-kernel-utils-5.0 (mlnx-ofed-kernel)…

-W- --with-mlx5-ipsec is enabled

Running /usr/bin/dpkg-buildpackage -us -uc

Failed to build mlnx-ofed-kernel DEB

Collecting debug info…

See /tmp/MLNX_OFED_LINUX-5.0-

I also tried to install the packages that was mentioned in the log, and below are the messages I got. I found that the all the packages has already installed.

# apt-get install bzip2 debhelper dh-autoreconf quilt gcc pkg-config build-essential make

Reading package lists… Done

Building dependency tree

Reading state information… Done

build-essential is already the newest version (12.4ubuntu1).

dh-autoreconf is already the newest version (17).

make is already the newest version (4.1-9.1ubuntu1).

pkg-config is already the newest version (0.29.1-0ubuntu2).

quilt is already the newest version (0.63-8.2).

bzip2 is already the newest version (1.0.6-8.1ubuntu0.2).

debhelper is already the newest version (11.1.6ubuntu2).

gcc is already the newest version (4:7.4.0-1ubuntu2.3).

0 upgraded, 0 newly installed, 0 to remove and 164 not upgraded.

Hello Eric,

Thank you for posting your inquiry on the Mellanox Community.

Regarding the dependency installation, the output of that log file simply details which prerequisite packages were installed in order to facilitate the MLNX_OFED installation process. The output shows that the script did, indeed, successfully install those packages at that time.

However, further down, the output states “Failed to build mlnx-ofed-kernel DEB”.

Underneath, it refers to another log file:

/tmp/MLNX_OFED_LINUX-5.0-”; which will contain further information as to why the mlnx-ofed-kernel DEB package build failed.

Based on the uname -a output you provided, you are attempting installation while running a kernel that is not explicitly supported on Ubuntu 18.04. In the release notes for MLNX_OFED 5.0-; it states that we only guarantee full compatibility with kernel version 4.15.0-20-generic for x86_64 architectures on Ubuntu 18.04:

Regrettably, beyond referring you to the debbuild.log file above, we are unable to provide further assistance with build issues encountered while running unsupported kernels.

Best regards,

Mellanox Technical Support