Invalid Target Board

I just received my Jetson TX1 and started the flashing process. I am having trouble flashing because I keep getting an error stating Invalid target board -jetson-tx1. when I use the command,

sudo /home/ayman/Linux_for_Tegra/flash.sh -r -S 14GiB jetson-tx1 mmcblk0p1

Can anyone help with this issue?

Have you tried using p2371-2180 as the target board?
Also which L4T are you using?

Also are you flashing from a host?
You can always use Jetpack which is the easier option.

How can I flash from jetpack?

Download from there https://developer.nvidia.com/embedded/jetpack
Make it executable using chmod.
You do need a linux x86 machine for this, well for either methods.

I just tried it, for some reason, when i input the command lsusb, i don’t find the jetson

You need to put it in recovery mode first.
To do so press the power button, then press and hold down the rec button which is next to the power button. While holding the rec button press the reset button and continue holding the rec button for 2 more seconds. If that was too confusing look up recovery mode TX1.

Got it finally thanks a lot guys. Appreciate the help.

someone has changed the default password, so I am flashing jetson-tk1 from raspberry pi 2 with ubuntu mate 16.04 but at the last step it shows Invalid Target Board. Please help.

Flash requires an x86_64 Linux host. RPi and RPi2 will not work.

One thing I see which might or might not be a problem is that I see the flash commands are run with full path. Some file content is using a relative path to the current working directory, so if you are not actually in the flash.sh directory at the time it is run you might get mysterious failures due to that.

Here is a note/summary on command line flashes:
https://devtalk.nvidia.com/default/topic/982779/jetson-tk1/how-to-perform-a-correct-fresh-ubuntu-install-on-jetson-tk1/post/5040584/#5040584