Flash script not working - invalid target board

Hi!

I was trying to flash my custom kernel module following the official documentation, when I try executing the flash.sh script in JetPack_4.3_Linux_P2888/Linux_for_Tegra I get the following error: Error: Invalid target board -

Following the documentation I tried:

sudo ./flash.sh jetson-nano mmcblk0p1

I also tried sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1 with the same result.

Did I miss anything?

1 Like

Hi,

JetPack_4.3_Linux_P2888 -> This is folder for Jetson Xavier.

You are right, many thanks for the correction. After I made sure to set the correct board in NVIDIA SDK the correct directory was created with P3448 suffix and flash command like this worked:

sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1

I think it would be good idea to specify target boards better in the documentation - running it with “jetson_nano” as target doesn’t seem to work.

1 Like

Hi,

You could also check what are other files under the folder Linux_for_Tegra.
The *.conf file indicate the target board name.

For example,

jetson-nano-emmc.conf -> This would be in use when you try command “sudo ./flash jetson-nano-emmc mmcblk0p1”

However, if I type any random target board like -> “sudo ./flash jetson-123 mmcblk0p1”
Then it would not work because there is no “jetson-123.conf” file under this folder. If you create one, and with a valid format, then it could work too.

That sounds good, many thanks for the extra info, it really helps in getting a bigger picture.

1 Like