Isaac 2023.1.0 examples slow and buggy

Hi,
Ah yes, but sometimes the localhost Nucleus cannot login, anyways, it’s working now.

And just like I said, I combined the ant demo with livestream, and I found the Gridclone has a code bug. I have fixed it like this: (the bug is the get_clone_tranforms function can not get the prim_paths from clone function)

    def get_clone_transforms(
        self,
        num_clones: int,
        position_offsets: np.ndarray = None,
        orientation_offsets: np.ndarray = None,
    ):
        if position_offsets is not None:
            if len(position_offsets) != len(self.prim_paths):
                raise ValueError("Dimension mismatch between position_offsets and prim_paths!")
            # convert to numpy array
            if isinstance(position_offsets, torch.Tensor):
                position_offsets = position_offsets.detach().cpu().numpy()
            elif not isinstance(position_offsets, np.ndarray):
                position_offsets = np.asarray(position_offsets)
        if orientation_offsets is not None:
            if len(orientation_offsets) != len(self.prim_paths):
                raise ValueError("Dimension mismatch between orientation_offsets and prim_paths!")
            # convert to numpy array
            if isinstance(orientation_offsets, torch.Tensor):
                orientation_offsets = orientation_offsets.detach().cpu().numpy()
            elif not isinstance(orientation_offsets, np.ndarray):
                orientation_offsets = np.asarray(orientation_offsets)
......
    def clone(
        self,
        source_prim_path: str,
        prim_paths: List[str],
        position_offsets: np.ndarray = None,
        orientation_offsets: np.ndarray = None,
        replicate_physics: bool = False,
        base_env_path: str = None,
        root_path: str = None,
        copy_from_source: bool = False,
    ):
        self.prim_paths = prim_paths # use to transfer the paths to get_clone_transforms function


Then, when I running this demo, there is another error: [Error] [gpu.foundation.plugin] Failed to read texture cache file /home/username/.cache/ov/texturecache/WireframeBlur_blue_92_1_1697585919_1474958_6.ovtex.5

1 Like

The latest version runs significantly slower for me compared to past versions, so I reverted back to the 2022.2.1 version. I’m unsure of the cause. With the numerous updates in this version, perhaps my code isn’t compatible with the changes.

@user15623 - You should always update to the latest version.

The Omniverse isaac gym is very slow. It takes a long time to run a training session for the following:

I have tried two commands, but both of them take a significant amount of time to execute.

  1. PYTHON_PATH scripts/rlgames_train.py task=Humanoid

I managed to execute it successfully once. However, I encountered an error at that time, but I didn’t log the details of the error. So I decided to log the output into a log.txt file.

  1. PYTHON_PATH scripts/rlgames_train.py task=Humanoid > log.txt 2>&1 (takes even longer to execute)

Nevertheless, it seems to be stuck at this point.



The most important CPU information for understanding the performance of your CPU are:

  • Architecture: x86_64 - CPU op-mode(s): 32-bit, 64-bit - Number of CPU(s): 32 - Threads per core: 2 - Cores per socket: 16 - Model name: AMD Ryzen 9 5950X 16-Core Processor - CPU frequency boost: enabled - CPU MHz (current frequency): 2200.000 - CPU max MHz: 3400.0000 - CPU min MHz: 2200.0000 - L1d cache: 512 KiB - L1i cache: 512 KiB

For Omniverse isaac gym, please refer to this thread: The Omniverse Isaac Gym is painfully slow. · Issue #103 · NVIDIA-Omniverse/OmniIsaacGymEnvs · GitHub

1 Like