Isaac/Samples/ROS2/Scenario/turtlebot_tutorial.usd NOT working


I am using Ubuntu 22.04 with ROS2 Humble along with Isaac Sim 2023.1.0.
I played the turtlebot_tutorial simulation in Isaac sim and opened rviz on a sourced terminal.
Additionally I set the use_sim _time to True.
But I am still unable to see the RViz image as shown in the tutorial.

Am I doing something wrong here?
If I create my own usd with RTX LiDAR, I can see the point cloud and laser scan - so atleast the ROS2 extension is working.


Hi @rudresh.lonkar, just a user here but maybe I can help. What is the topic of the image in RViz? Is it the same as the one in the action graph in Isaac Sim?

Hey @scn , thanks for your reply. It is the same as the action graph. Please note that I am using 2023.1.0.
Do you manage to see the images in your system?

Hi @rudresh.lonkar yes I am seeing images (fyi I am running it on a Windows machine). I don’t know if its possible for you to share your actiongraph file? Then I could take a look here, otherwise a few screenshots might help.

I assume you are following the tutorial here: 7.1.3. Cameras — Omniverse IsaacSim latest documentation - If that is the case I would also double check the values in the table first match the ones in the actiongraph:

Node Input Field Value
Isaac Create Viewport name New Viewport
Isaac Set Camera cameraPrim /World/Camera_1
ROS1 Camera Helper type rgb
topicName rgb
frameId turtle

Hey @scn , I am following 7.2.3. ROS2 Cameras — Omniverse IsaacSim latest documentation since I use ROS2.

For the action graphs, since I am using the usd provided by NVIDIA, I think you can also access it from omniverse://localhost/NVIDIA/Assets/Isaac/2023.1.0/Isaac/Samples/ROS2/Scenario/turtlebot_tutorial.usd.

The values in the ROS2 helper node are different, shown below-

Hi @rudresh.lonkar - That was my bad, ROS and ROS 2 tutorial for the camera look so similar :)

Can you leaving the nodenamespace empty and change the frameId to turtle?

Hey @scn , I tried leaving nodenamespace empty and changed the frameid to turtle, but still cannot see the image.

Hi @rudresh.lonkar I am trying to reproduce your issue and have successfully been able to recreate it. I am trying to find the solution here and will let you know asap if I figure something out.

I also have RTX Lidar setup and now trying to add a camera :) hopefully we can solve this together!

Can you share your action graph for the camera if you have created one?

Hey @scn, here is the image of the action graph I created which currently works with RViz. Let me know if there is any better way to share this apart from the screenshot.

1 Like

It looks like this particular camera is not enabled. check the box next to “enabled”.
the other things to check is that the fixed frame for this asset should be “world”, and the image topic should be “camera_1/rgb/image_raw”. Let me know if those don’t help.

Hi @rudresh.lonkar

Thanks for sharing the diagram. Can you check the target prims in the publish tree node and make sure your camera meshes are there?

Let me know if you want to jump on a call and try to debug it together as I am also learning 🙌😊

Hey @qwan, the points mentioned helped, I can now see the cameras in RViz. Thanks for the help!
Hey @scn, the new updated files from the sample worked for me. I can see everything now, but if you are still facing issues, I’d be happy to jump on a call to help with this or the LiDAR!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.