Isaac Sim 2022.2.0 ROS2_bridge not starting automatically even when AUTOLOAD is set

Hello there,


  • Omniverse 2022.2.0 (native install)
  • Ubuntu 20.04
  • ROS2 Foxy

I have an annoying issue since everytime I launch omniverse and load my ROS2 based scene, it removes all the ROS2 nodes in the node graph to access ROS2 topics. This is simply because every time I launch Isaac Sim, the ROS_bridge extension is enabled by default and therefore the ROS2_bridge is unable.

The terminal with Omniverse gives the following error:

2023-01-11 10:47:36 [7,905ms] [Error] [omni.isaac.ros2_bridge.scripts.extension] ROS2 bridge extension cannot be enabled if omni.isaac.ros_bridge is disabled

In the “Window | Extension” menu, I disable the ROS_bridge extension and enable the ROS2_bridge extension. I unchecked the AUTOLOAD box for the ROS_bridge and check it for ROS2_bridge. Yet, every time, the ROS2_bridge is disabled and the ROS_bridge is enabled after the launch.

Am I doing something wrong or is this a bug in Omniverse?

Hi @dave.vandermeer.001

omni.isaac.ros_bridge is enabled by default in apps/omni.isaac.sim.base.kit file

You can enable the omni.isaac.ros2_bridge extension by default by modifying the apps/omni.isaac.sim.base.kit file, line 554 (like this post, but updated for 2022.2.0) as follow:

#linux only extensions
"omni.isaac.ros2_bridge" = {}

File location:

  • docker container: /isaac-sim/apps/omni.isaac.sim.base.kit
  • local workstation: ~/.local/share/ov/pkg/isaac_sim-2022.2.0/apps/omni.isaac.sim.base.kit

Thanks, this works for me.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.