Isaac Sim Crashed when adding ROS Context action graph in Windows with ROS-foxy

crash_2023-08-23_16-44-55_23892.txt (8.8 KB)

Attached log file.
Using NVIDIA GeForce RTX 3060 Driver Version: 536.67 and Isaac Sim 2022.2.1 release.
Followed the Window ROS-2 foxy installation guide at 6. ROS & ROS 2 Installation — isaacsim latest documentation.

Enabled ros2_bridge
image

Crashed when adding ROS2 Context to action graph.

@skl1g14 i am just another user passing by. based on the hardware and log information provided and assuming you were followed through with the installation steps, can you try two things and see if they help with the crashes on your end?

  1. disabling the other GPU that’s not RTX - you can do this through the device manager > display adapters > right click on the Intel Iris Xe Graphics device and “Disable device”
  2. try changing the display driver version - the recommended driver version can be found in the Issac Sim driver requirement doc.
1 Like

Hi @Simplychenable, I have similar thoughts as you. From the crash log, i suspect this window library to be the culprit ucrtbase.dll!terminate+0x22. Upon digging further, there are other reports mostly from games or graphics application sites mentioning its related to the display drivers.

For now i have move on to a Linux system which run more smoother. May revisit this again.

1 Like

the doc does seem to indicate Linux is better suited for ROS2, so sounds like you are on the right track:

Thanks for the reply.

For others visiting this topic. I have tried WSL2 but couldnt get what i need to work. Best to have a native Linux system.

I have not tried using docker yet.

maybe it’s because it’s not yet supported - My issac sim at omniverse in wsl2 can not launch - #5 by Sheikh_Dawood

hi @skl1g14 and @Simplychenable , with the changes in the ROS 2 bridge with Isaac Sim, it should be working on Windows as expected. WSL2 also works with the ROS 2 bridge enabled in Isaac Sim Windows and the WSL Ubuntu instance running ROS 2. We did run into issues while testing this, please make sure you follow the Isaac Sim ROS 2 docs (specifically setting DOMAIN_ID and the fastrtps config file) to start out initially. Hope this helps!

1 Like