Crashes when ROS2 Humble Bridge is Enabled


I am trying to run IsaacSim with ROS2 Humble Bridge and I’m having some problems. IsaacSim runs without problem when ROS2 Humble Bridge is disabled. However if ROS2 Humble bridge is enabled, the program crashes and closes when i press the play button. I already tried to uninstall and install the program but the problem didn’t solved. Besides, i cannot enable ROS2 bridge instead of ROS2 Humble Bridge becouse I’m getting an error saying that i cannot enable ROS2 and ROS2 Humble bridges together even though i already disabled Humble one.

I am working on Ubuntu 22.04 and working with IsaacSim 2022.2.0.
Here is the output from nvidia-smi:

Also the log file is given. (about crashes when ROS2 Humble Bridge is enabled)
kit_20230130_084947.log (1.8 MB)

Could you help me to fix these problems?


See if this helps you: Issac Sim 2022.2.0 | ROS2 Humble crash - #5 by Hammad_M

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.