Isaac Sim 2022.2.0 | ROS2 Humble crash

Hello, I want to use ROS2 Humble with Isaac Sim. I enabled the ROS2_humble bridge. Whenever I add a node like ‘ROS2 Context’ to the omnigraph, Isaac Sim crashes.


Hello, I am also having issue when adding the ROS2 Context node, Isaac Sim crashes with use of Humble. But can add other ROS2 nodes like the ROS2 Subscribe Twist

I didn’t get a solution. So I switched to Ubuntu 20.04. Now I am using ROS2 Foxy and everything works fine.

Dang. I’m having the same issue and can’t afford to switch to foxy as all other systems my company runs are in humble. It would still be great to know why this is happening

Thank you for the suggestion yadun. Didnt find any solution so i also switched to Linux 20.04 and foxy and it all worked perfect straight away.

juan17, i saw some topic where they talk about issue with ROS2 that will be solved in version 2022.2.1, hope that will solve issues for you

I am currently working on Ubuntu 22.04 with ROS 2 Humble and Isaac Sim ros2_bridge(not ros2_humble_bridge). As far as I know, ros2_humble_bridge is a beta version so you can do it with ros2_bridge now.

It is crashing for me.

I am running Isaac Sim 2022.2.0 in Ubuntu Ubuntu 22.04.2 LTS and have tried with both the RO2 Humble Bridge v1.10.1 and ROS2 Bridge v1.10.1

Here are the steps I’m following:

Launch Isaac Sim 2022.2.0
Enable extension for ROS2 Humble Bridge v1.10.1
Create new empty action graph
Drag ROS2 Context to action graph
GUI hangs then disappears, with crash dump in the logs (attached)

kit_20230307_142718.log (1.7 MB)
kit_20230307_143054.log (1.7 MB)

1 Like

This issue will be fixed with 2022.2.1 releasing soon.

1 Like