Isaac sim crashes multiple displays

Hi Everyone,

With a fresh install of omniverse and trying to launch isaac sim it fails to start when multiple displays are attached. Lanuching it manually from the command line with

/home/jasper/.local/share/ov/pkg/isaac_sim-2023.1.1/isaac-sim.sh -v --reset-user

shows the same issue as Isaac Sim 2023.1.0 Fails Due to Vulkan Issue on Ubuntu 20.04 so I disabled my extra monitors. It then launches ok.

But if used with an external monitor (even with the laptop display turned off) it will run for 3-15 seconds before hanging.

If I run it on an external display (1080 or 4k doesn’t matter, HDMI or DisplayPort doesn’t matter) it will hang, but running it on my laptop display it works fine.

The crash looks like a display freeze, the isaac sim process is still alive but in S state (interruptable sleep). The monitor that isaac is on stops responding altogether. Other programs are also affected.

I was able to boot isaac and load a demo program while running on my laptop screen (it doesn’t crash in this mode). I can enable and use an external monitor, as soon as I move the issac window onto that screen, isaac and everything on that screen freezes. The laptop screen remains working normally.

Using an RTX4606 with drivers 535.171.04 and cuda 12.2 (also tried the 550 drivers but they did not help). Ubuntu 22.04.

On a laptop with 2 4k external monitors and a 1080 internal screen.

This is what nvidia-smi looks like when the crash happens

+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 535.171.04             Driver Version: 535.171.04   CUDA Version: 12.2     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  NVIDIA GeForce RTX 4060 ...    Off | 00000000:01:00.0  On |                  N/A |
| N/A   73C    P0              62W /  80W |   3036MiB /  8188MiB |     81%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|    0   N/A  N/A      2161      G   /usr/lib/xorg/Xorg                           77MiB |
|    0   N/A  N/A      4536    C+G   ...e/ov/pkg/isaac_sim-2023.1.1/kit/kit     2939MiB |
+---------------------------------------------------------------------------------------+

I don’t think it’s an out of memory issue given the process is alive and both ram and vram look ok (I’ve got 32GB of ram with 20GB of swap). The linux kernel logs don’t show anything. It seems to only happen with isaac sim.

Has anyone else seen this issue with external monitors freezing? Any suggestions on how to debug this?

Hello jasper, I was the original poster of the prior issue and ended up isolating the behavior.

I haven’t had developer feedback, but the the best I can tell, the issue is in Isaac’s Vulkan renderer handling for some display configurations.

This means that it is unrelated to your CUDA version, as Vulkan does not interact with CUDA, or your Nvidia driver, as Vulkan seems stable for Nvidia in any display configuration when running its Vulkan’s test application.

Are there any error messages in your logs for Isaac?

Please share your display configuration for the freeze behavior, as it might give some insight. I notices that Isaac (in Ubuntu) prefers if all of your displays are aligned on the top portion of your screen. However, with 2 monitor configurations, I was not able to replicate the behavior.

I have never had the noted freeze behavior, as the issue was present during startup, preventing the application from ever launching. I could see how a similar exception would cause a program hang if the error presents in a different way during runtime.