Unable to launch Issan sim from my new desktop [RTX engine creation failed. RTX renderers in viewport will be disabled]

Hi all,

I am trying to run Issac sim on an external SSD (Using Ubuntu 20.04).
I was following this documentation to install it, but seems like it not working smoothly :(

The issue I am having is following

I have tried everything I can (Reinstalling the nvidia driver, checking vulkaninfo) but seems like it always fails to initiate.

The main error that I am getting is:
2022-10-02 20:00:44 [228ms] [Error] [carb.graphics-vulkan.plugin] VkResult: ERROR_INITIALIZATION_FAILED
2022-10-02 20:00:44 [229ms] [Error] [carb.graphics-vulkan.plugin] vkCreateDevice failed.
2022-10-02 20:00:44 [229ms] [Error] [gpu.foundation.plugin] No device could be created. Some known system issues:

  • The driver is not installed properly and requires a clean re-install.
  • Your GPUs do not support RayTracing: DXR or Vulkan ray_tracing, or hardware is excluded due to performance.
  • The driver cannot enumerate any GPU: driver, display or a docker issue. For Vulkan, test it with Vulkaninfo tool from Vulkan SDK, instead of nvidia-smi.
  • For Ubuntu, it requires server-xorg-core 1.20.7+ and a display to work without --no-window.
  • For Linux dockers, the setup is not complete. Install the latest driver, xServer and NVIDIA container runtime.

what would be the possible reason? Could you please help me out with this?
Below is the nvidia-smi and the log file from the kit:

Sun Oct 2 22:13:49 2022
| NVIDIA-SMI 510.85.02 Driver Version: 510.85.02 CUDA Version: 11.6 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 NVIDIA GeForce … Off | 00000000:01:00.0 On | N/A |
| 30% 31C P8 31W / 320W | 538MiB / 10240MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| 0 N/A N/A 2140 G /usr/lib/xorg/Xorg 239MiB |
| 0 N/A N/A 2458 G /usr/bin/gnome-shell 91MiB |
| 0 N/A N/A 5298 G /usr/lib/firefox/firefox 204MiB |

kit_20221002_220628.log (10.7 MB)

Thanks in advance!


Clean uninstalling the driver and reinstalling the recent release with the .run file solved the issue. I honestly don’t know what the problem was but seems like there was some kind of leftovers from the previous driver when I tried reinstalling.

If you have a similar problem with me, consider clean removing the driver and reinstalling it the way the official doc recommends: 1. Isaac Sim Requirements — Omniverse Robotics documentation

Search packages from nvidia you have installed:

dpkg -l | grep -i nvidia

Make sure you purge everything related to nvidia by this command:

sudo apt-get remove --purge '^nvidia-.*'

Also sometimes the nouveau driver gets blacklisted from nvidia driver. With the purge command, it should be unblacklisted. If you want to be sure that nouveau will be loaded in boot, you can force-load it by adding it to /etc/modules

echo 'nouveau' | sudo tee -a /etc/modules

Check once again if you have successfully removed previously installed drivers with:

dpkg -l | grep -i nvidia

Then, reinstalling the driver with the Latest Long-Lived Branch Version of the NVIDIA GPU Driver using the .run installer solved my problem :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.