Can't launch the isaac sim from omniverse launcher or python script

I can’t launch the isaac sim from omniverse launcher or python script.
I have removed the /usr/share/vulkan and /etc/vulkan and try reinstall nvidia driver three times . And clean the launcher and reinstall the issac sim three times,.
my os :ubuntu20.04

mylog is I run the command(base) pi@pi:~/.local/share/ov/pkg/isaac_sim-2023.1.0-hotfix.1$ ./ > mylog.txt
mylog.txt (34.3 KB)
kit_20231208_183500.log (759.5 KB)

How to solve the problem?
Thanks in advance.

@2436442868 i am just another OV user, but it seems the kit log you provided is older or has discrepancies between the screenshot you posted? because the log seems to indicate you are on driver 525.116.04 as opposed to 535.129.03 from the nvidia-smi:

which could be related to errors such as…

2023-12-08 10:35:01 [312ms] [Error] [omni.gpu_foundation_factory.plugin] Failed to create GPU foundation devices for compatibilityMode!
2023-12-08 10:35:01 [291ms] [Error] [] VkResult: ERROR_INCOMPATIBLE_DRIVER
2023-12-08 10:35:01 [291ms] [Error] [] vkCreateInstance failed. Vulkan 1.1 is not supported, or your driver requires an update.
2023-12-08 10:35:01 [291ms] [Error] [] carb::graphics::createInstance failed.

you could take a look at the Linux troubleshooting doc and see if you can update your driver to recommended version shown on the technical requirement doc. in addition, consider upgrading to Isaac Sim 2023.1.0 hotfix.1.

if you have a newer log, feel free to post it as well in case you uploaded an older log.

thank you for you replay.
the nvidia driver is not matching, because I install Isaac sim and then reinstall nvidia driver.
Now I clean the launcher and reinstall the cache, nucleus and Isaac sim.
but it doesn’t work, even worse.

i ran command (base) pi@pi:~/.local/share/ov/pkg/isaac_sim-2023.1.0-hotfix.1$ ./ > mylog2.txt

it say vkCreateInstance failed. Vulkan 1.1 is not supported, or your driver requires an update.
so I follow gpt suggestion to sudo apt-get remove --purge mesa-vulkan-drivers and sudo apt-get install vulkan-icd
and run (base) pi@pi:~/Downloads/vulkansdk-linux-x86_64-$ ./vulkaninfo > vulkaninfo.txt
vulkaninfo.txt (24.6 KB)

and run (base) pi@pi:~/.local/share/ov/pkg/isaac_sim-2023.1.0-hotfix.1$ ./ > mylog3.txt

and I follow the gpt suggestion to install vulkan SDK in LunarXchange

my last command is base) pi@pi:~/.local/share/ov/pkg/isaac_sim-2023.1.0-hotfix.1$ ./ > mylog4.txt
I have no idea to fix the bug. please help me out.

mylog2.txt (29.8 KB)
mylog3.txt (37.4 KB)

mylog4.txt (36.6 KB)

kit_20231209_130703.log (759.5 KB)

I fotget which step to reinstall dirver, but i sure that i reinstall driver.

1.I reinstall ubuntu20
2.I install nvidia driver535
3. I install omniverse
4. cache
6.issac sim
7. remove /usr/share/vulkan/icd.d
8.reinstall nvidia driver!!!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.