Isaac sim [libprotobuf FATAL google/protobuf/stubs/common.cc:79]

I was trying to run Omniverse Kit Remote Client (https://docs.omniverse.nvidia.com/app_isaacsim/app_isaacsim/setup.html#isaac-sim-setup-kit-remote) and encountered the following error in my log:

ubuntu@ip-10-0-255-71:~$ ifconfig docker0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 inet 172.17.0.1 netmask 255.255.0.0 broadcast 172.17.255.255 ether 02:42:a1:fd:67:99 txqueuelen 0 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 ens5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 9001 inet 10.0.255.71 netmask 255.255.255.192 broadcast 10.0.255.127 inet6 fe80::c38:cdff:fe86:64dd prefixlen 64 scopeid 0x20 ether 0e:38:cd:86:64:dd txqueuelen 1000 (Ethernet) RX packets 408806 bytes 537198058 (537.1 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 156354 bytes 19589495 (19.5 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10 loop txqueuelen 1000 (Local Loopback) RX packets 38768 bytes 4977252 (4.9 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 38768 bytes 4977252 (4.9 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 ubuntu@ip-10-0-255-71:~$ ./kit-remote.sh -s 54.164.131.32 ~/bin ~ [libprotobuf FATAL google/protobuf/stubs/common.cc:79] This program was compiled against version 3.0.0 of the Protocol Buffer runtime library, which is not compatible with the installed version (3.5.1). Contact the program author for an update. If you compiled the program yourself, make sure that your headers are from the same version of Protocol Buffers as your link-time library. (Version verification failed in “/build/mir-ATBFuS/mir-0.31.1/obj-x86_64-linux-gnu/src/protobuf/mir_protobuf.pb.cc”.) terminate called after throwing an instance of ‘google::protobuf::FatalException’ what(): This program was compiled against version 3.0.0 of the Protocol Buffer runtime library, which is not compatible with the installed version (3.5.1). Contact the program author for an update. If you compiled the program yourself, make sure that your headers are from the same version of Protocol Buffers as your link-time library. (Version verification failed in “/build/mir-ATBFuS/mir-0.31.1/obj-x86_64-linux-gnu/src/protobuf/mir_protobuf.pb.cc”.) ./kit-remote.sh: line 28: 15091 Aborted (core dumped) ./kit-remote $@ ~ ubuntu@ip-10-0-255-71:~$

Hi, are you still seeing this issue?

In version 2021.2.1, we recommend using WebSocket livestreaming.