[Solved] Failed to setup Kit Remote client on Ubuntu 20.04

Hi there, I installed Isaac Sim on my laptop with

  • OS: Ubuntu 20.04
  • GPU: RTX 3070
  • Nvidia driver: 460.91

I can launch Isaac Sim and Isaac Sim WebSocket normally, but no lucks on Kit Remote. Here are my logs, can someone give me some advice?

Server side:

$ ./isaac-sim.headless.kitremote.sh --enable omni.kit.livestream.native

Summary

[Info] [carb] Logging to file: /home/cavedu/.nvidia-omniverse/logs/Kit/Isaac-Sim/2021.1/kit_20210818_005954.log
[Info] [carb] Initializing plugin: carb.events.plugin (interfaces: [carb::events::IEvents v0.2]) (impl: carb.events.plugin)
[0.013s] Loading user config located at: ‘/home/cavedu/.local/share/ov/data/Kit/Isaac-Sim/2021.1/user.config.json’
2021-08-17 16:59:54 [73ms] [Warning] [omni.ext.plugin] Extension with the same id is already registered. ext_id: ‘omni.kit.xr-1.0.0’, ext 1: ‘/home/cavedu/.local/share/ov/pkg/isaac_sim-2021.1.1/kit/exts/omni.kit.xr’, ext 2: ‘/home/cavedu/.local/share/ov/pkg/isaac_sim-2021.1.1/kit/extscore/omni.kit.xr’
[0.091s] [ext: omni.usd.config-1.0.0] startup
[0.092s] [ext: omni.usd.libs-1.0.0] startup
[0.267s] [ext: omni.kit.pipapi-0.0.0] startup
[0.272s] [ext: omni.usd.schema.semantics-0.0.0] startup
[0.277s] [ext: omni.usd.schema.audio-0.0.0] startup
[0.281s] [ext: omni.hydra.iray-0.1.0] startup
[0.284s] [ext: omni.kit.pip_archive-0.0.0] startup
[0.289s] [ext: omni.kit.loop-default-0.1.0] startup
[0.289s] [ext: omni.kit.async_engine-0.0.0] startup
[0.300s] [ext: omni.stats-0.0.0] startup
[0.302s] [ext: omni.assets.plugins-0.0.0] startup
[0.303s] [ext: omni.appwindow-1.0.0] startup
[0.320s] [ext: omni.client-0.1.0] startup
[0.328s] [ext: omni.kit.test-0.0.0] startup
[0.341s] [ext: omni.kit.renderer.core-0.0.0] startup

|---------------------------------------------------------------------------------------------|
| Driver Version: 460.91 | Graphics API: Vulkan
|=============================================================================================|
| GPU | Name | Active | LDA | GPU Memory | Vendor-ID | LUID |
| | | | | | Device-ID | UUID |
|---------------------------------------------------------------------------------------------|
| 0 | GeForce RTX 3070 Laptop GPU | Yes | | 16374 MB | 10de | 0 |
| | | | | | 249d | bb394242… |
|---------------------------------------------------------------------------------------------|
| 1 | AMD RADV RENOIR (ACO) | | | 512 MB | 1002 | 0 |
| | | | | | 1638 | 00000000… |
|=============================================================================================|
| OS: Linux cavedu-ASUS-TUF-Gaming-A15-FA506QR-FA506QR, Version: 5.11.0-27-generic
| Processor: AMD Ryzen 7 5800H with Radeon Graphics | Cores: Unknown | Logical: 16
|---------------------------------------------------------------------------------------------|
| Total Memory (MB): 23511 | Free Memory: 19352
| Total Page/Swap (MB): 2047 | Free Page/Swap: 2047
|---------------------------------------------------------------------------------------------|
[0.930s] [ext: omni.ui-2.1.8] startup
[0.945s] [ext: omni.kit.mainwindow-0.0.0] startup
[0.948s] [ext: omni.kit.uiapp-0.0.0] startup
[0.948s] [ext: omni.usd.schema.physics-1.0.0] startup
[0.955s] [ext: omni.usd.schema.physx-0.0.0] startup
[0.971s] [ext: omni.usd.schema.anim-0.0.0] startup
[0.982s] [ext: omni.usd.schema.isaac-0.1.0] startup
[1.000s] [ext: omni.hydra.scene_delegate-0.1.0] startup
[1.008s] [ext: carb.audio-0.1.0] startup
[1.010s] [ext: omni.timeline-1.0.0] startup
[1.013s] [ext: omni.kit.commands-0.0.0] startup
[1.018s] [ext: omni.kvdb-0.0.0] startup
[1.020s] [ext: omni.usd-1.4.2] startup
[1.045s] [ext: omni.localcache-0.0.0] startup
[1.048s] [ext: omni.kit.window.drop_support-1.0.0] startup
[1.050s] [ext: omni.convexdecomposition-1.2.0] startup
[1.054s] [ext: omni.usdphysics-1.2.0] startup
[1.055s] [ext: omni.kit.menu.utils-1.0.1] startup
[1.064s] [ext: omni.physx-1.2.0-5.1] startup
[1.111s] [ext: omni.kit.material.library-1.0.4] startup
[1.121s] [ext: omni.kit.menu.create-1.0.1] startup
[1.125s] [ext: omni.renderer-rtx-0.0.0] startup
[1.126s] [ext: omni.kit.context_menu-1.1.0] startup
[1.217s] [ext: omni.hydra.rtx-0.1.0] startup
[1.219s] [ext: omni.services.facilities.base-1.0.0] startup
[1.221s] [ext: omni.kit.window.viewport-0.0.0] startup
2021-08-17 16:59:55 [1,212ms] [Warning] [omni.ext.plugin] [ext: omni.kit.window.viewport-0.0.0] ‘/home/cavedu/.local/share/ov/pkg/isaac_sim-2021.1.1/kit/plugins/rtx/rtx.reshade.plugin’ in ‘[[native.plugin]]’ was not found.
2021-08-17 16:59:56 [2,037ms] [Warning] [carb] Acquiring non optional plugin interface which is not listed as dependency: [rtx::raytracing::Subsurface v0.1] (plugin: rtx.raytracing.plugin), by client: carb.scenerenderer-rtx.plugin. Add it to CARB_PLUGIN_IMPL_DEPS() macro of a client.
[2.332s] [ext: omni.services.core-1.1.0] startup
[2.459s] [ext: omni.services.transport.client.base-1.0.0] startup
[2.462s] [ext: omni.services.transport.server.base-1.0.0] startup
[2.465s] [ext: omni.services.client-0.2.0] startup
[2.485s] [ext: omni.services.transport.server.http-1.0.0] startup
[2.537s] [ext: omni.kit.agent-0.1.0] startup
[2.540s] [ext: omni.services.transport.client.http_async-1.0.0] startup
[2.685s] [ext: omni.kit.widget.stage-2.4.0] startup
[2.694s] [ext: omni.kit.thumbnails.images-0.1.1] startup
[2.699s] [ext: omni.kit.search_core-1.0.0] startup
[2.704s] [ext: omni.kit.window.popup_dialog-2.0.0] startup
[2.708s] [ext: omni.kit.widget.path_field-2.0.2] startup
[2.714s] [ext: omni.kit.widget.filebrowser-2.2.4] startup
[2.722s] [ext: omni.kit.notification_manager-1.0.0] startup
[2.727s] [ext: omni.kit.widget.browser_bar-2.0.1] startup
[2.731s] [ext: omni.kit.window.toolbar-1.0.0] startup
[2.739s] [ext: omni.kit.numpy.common-0.1.0] startup
[2.827s] [ext: omni.kit.window.filepicker-2.3.1] startup
[2.879s] [ext: omni.isaac.contact_sensor-0.1.0] startup
[2.887s] [ext: omni.debugdraw-0.0.0] startup
[2.892s] [ext: omni.syntheticdata-0.1.5] startup
[2.962s] [ext: omni.isaac.dynamic_control-0.1.3] startup
[2.975s] [ext: omni.isaac.ros_bridge_ui-0.1.0] startup
[2.980s] [ext: omni.isaac.range_sensor-0.1.2] startup
[2.991s] [ext: omni.isaac.utils-0.1.4] startup
[3.004s] [ext: omni.kit.stage_templates-1.0.4] startup
[3.010s] [ext: omni.isaac.ros_bridge-0.1.0] startup
Checking if ROS_MASTER_URI is set:
ROS_MASTER_URI not set, using default, ROS_MASTER_URI= http://localhost:11311
[3.127s] [ext: omni.kit.window.file-1.2.2] startup
[3.186s] [ext: omni.kit.window.property-0.0.0] startup
[3.193s] [ext: omni.isaac.occupancy_map-0.1.0] startup
[3.223s] [ext: omni.kit.window.content_browser-2.3.1] startup
[3.265s] [ext: omni.kit.property.usd-3.9.4] startup
[3.287s] [ext: omni.kit.widget.settings-1.0.0] startup
[3.293s] [ext: omni.physx.commands-1.0.0] startup
[3.297s] [ext: omni.kit.property.material-1.6.4] startup
[3.305s] [ext: omni.kit.window.preferences-1.1.1] startup
[3.341s] [ext: omni.physx.ui-1.2.0-5.1] startup
[3.355s] [ext: omni.kit.renderer.capture-0.0.0] startup
[3.362s] [ext: omni.kit.property.physx-0.1.0] startup
[3.411s] [ext: omni.physx.demos-1.0.0] startup
[3.416s] [ext: omni.isaac.window.about-1.0.0] startup
[3.421s] [ext: omni.physx.vehicle-1.2.0-5.1] startup
[3.443s] [ext: omni.command.usd-1.0.1] startup
[3.448s] [ext: omni.physx.cct-1.2.0-5.1] startup
[3.463s] [ext: omni.kit.widget.stage_icons-1.0.1] startup
[3.470s] [ext: omni.kit.widget.layers-1.5.2] startup
[3.486s] [ext: omni.kit.menu.select-1.0.0] startup
[3.496s] [ext: omni.physx.bundle-1.2.0-5.1] startup
[3.496s] [ext: omni.kit.window.stage-2.3.3] startup
[3.505s] [ext: omni.kit.property.layer-1.1.0] startup
[3.517s] [ext: omni.kit.tool.collect-2.0.1] startup
[3.527s] [ext: omni.kit.thumbnails.usd-0.3.0] startup
[3.564s] [ext: omni.kit.property.isaac-0.1.0] startup
[3.571s] [ext: omni.kit.usd_undo-0.1.0] startup
[3.577s] [ext: omni.kit.property.audio-1.0.4] startup
[3.585s] [ext: omni.kit.property.camera-1.0.3] startup
[3.600s] [ext: omni.kit.property.geometry-1.1.0] startup
[3.608s] [ext: omni.kit.property.light-1.0.4] startup
[3.615s] [ext: omni.kit.property.transform-1.0.2] startup
[3.624s] [ext: omni.kit.window.console-0.0.0] startup
[3.626s] [ext: omni.kit.asset_converter-1.1.22] startup
[3.645s] [ext: omni.kit.primitive.mesh-1.0.0] startup
[3.654s] [ext: omni.kit.window.tests-0.1.0] startup
[3.728s] [ext: omni.kit.property.bundle-1.2.4] startup
[3.736s] [ext: omni.kit.window.usd_paths-1.0.3] startup
[3.745s] [ext: omni.isaac.shapenet-1.0.0] startup
env var SHAPENET_LOCAL_DIR not set, using default data dir /home/cavedu/.local/share/ov/data/Kit/Isaac-Sim/2021.1/shapenet
omni.isaac.shapenet’s receiver for external messages has started. on (‘localhost’, ‘7011’)
[3.796s] [ext: semantics.schema.editor-0.1.3] startup
[3.799s] [ext: omni.isaac.tests-0.0.0] startup
[3.805s] [ext: omni.graph.tools-1.0.0] startup
[3.820s] [ext: omni.graph.core-1.0.0] startup
[3.823s] [ext: omni.kit.widget.fast_search-0.3.0] startup
[3.831s] [ext: omni.kit.widget.graph-1.1.2] startup
[3.842s] [ext: omni.kit.widget.prompt-1.0.0] startup
[3.850s] [ext: omni.kit.widget.imageview-1.0.0] startup
[3.858s] [ext: omni.graph-1.0.0] startup
[3.906s] [ext: omni.isaac.dr-0.1.6] startup
[3.917s] [ext: omni.kit.widget.live-0.0.0] startup
[3.919s] [ext: omni.rtx.window.settings-0.6.0] startup
[3.926s] [ext: omni.kit.window.imageviewer-1.0.3] startup
[3.937s] [ext: omni.graph.ui-1.0.1] startup
[3.999s] [ext: omni.kit.menu.file-1.0.2] startup
[4.007s] [ext: omni.kit.window.cursor-1.0.1] startup
[4.017s] [ext: omni.rtx.settings.core-0.5.4] startup
[4.026s] [ext: omni.kit.window.status_bar-0.0.0] startup
[4.028s] [ext: omni.kit.window.script_editor-1.5.0] startup
[4.030s] [ext: omni.videoencoding-0.0.0] startup
[4.037s] [ext: omni.kit.tagging-0.1.0] startup
[4.159s] [ext: omni.kit.widget.sliderbar-1.0.3] startup
[4.168s] [ext: omni.iray.settings.core-0.6.2] startup
[4.176s] [ext: omni.kit.capture-0.4.0] startup
[4.187s] [ext: omni.kit.window.commands-0.1.1] startup
[4.197s] [ext: omni.kit.menu.edit-1.0.3] startup
[4.209s] [ext: omni.kit.filebrowser_column.tags-1.0.0] startup
[4.217s] [ext: omni.kit.window.movie_maker-0.4.9] startup
[4.228s] [ext: omni.kit.tool.asset_importer-2.3.2] startup
[4.240s] [ext: omni.isaac.robot_engine_bridge_ui-0.1.0] startup
[4.253s] [ext: omni.kit.window.title-1.1.0] startup
[4.262s] [ext: omni.isaac.motion_planning-0.1.4] startup
[4.274s] [ext: omni.isaac.manip-0.1.2] startup
[4.285s] [ext: omni.kit.search.service-0.1.0] startup
[4.296s] [ext: omni.isaac.step_importer-0.1.1] startup
[4.356s] [ext: omni.isaac.robot_engine_bridge-0.1.0] startup
[4.707s] [ext: omni.isaac.urdf-0.1.4] startup
[4.725s] [ext: omni.isaac.synthetic_utils-0.1.0] startup
[4.738s] [ext: omni.isaac.samples-0.1.6] startup
[4.767s] [ext: omni.kit.selection-0.0.0] startup
[4.781s] [ext: omni.ansel-0.2.0] startup
2021-08-17 16:59:58 [4,769ms] [Warning] [omni.ext.plugin] [ext: omni.ansel-0.2.0] Failed to load plugins, folder doesn’t exist: ‘/home/cavedu/.local/share/ov/pkg/isaac_sim-2021.1.1/kit/exts/omni.ansel/bin’.
2021-08-17 16:59:58 [4,769ms] [Warning] [omni.ext.plugin] [ext: omni.ansel-0.2.0] ‘/home/cavedu/.local/share/ov/pkg/isaac_sim-2021.1.1/kit/exts/omni.ansel/bin/*.plugin’ in ‘[[native.plugin]]’ was not found.
[4.788s] [ext: omni.kit.window.extensions-1.0.2] startup
[4.801s] [ext: omni.graph.examples.python-1.0.0] startup
[4.854s] [ext: omni.kit.window.profiler-1.0.0] startup
[4.864s] [ext: omni.isaac.utils_manager-0.1.0] startup
[4.874s] [ext: omni.isaac.app.setup-0.0.0] startup
[4.883s] [ext: omni.kit.window.stats-0.0.0] startup
[4.895s] [ext: omni.isaac.sim.base-2021.1.1] startup
[4.895s] [ext: omni.kit.livestream.core-0.0.0] startup
[4.905s] [ext: omni.isaac.sim.headless.base-2021.1.1] startup
[4.905s] [ext: omni.kit.livestream.native-0.0.0] startup

Active user not found. Using default user [kiosk]Streaming server started.[5.005s] [ext: omni.isaac.sim.headless.kitremote-2021.1.1] startup
[5.006s] app started
2021-08-17 17:00:00 [6,667ms] [Warning] [carb.graphics-vulkan.plugin] Physical device with name: llvmpipe (LLVM 12.0.0, 256 bits) does not support ‘Vulkan 1.1’, it has api version: 1.0.
2021-08-17 17:00:00 [6,848ms] [Warning] [carb.graphics-vulkan.plugin] Physical device with name: llvmpipe (LLVM 12.0.0, 256 bits) does not support ‘Vulkan 1.1’, it has api version: 1.0.
Isaac Sim Headless Kit Remote App is loaded.
Checking for Isaac Sim assets on nucleus server
Check successful

Client side:

$ ./kit-remote.sh -s 10.42.0.30 -w 1920 -h 100
(where 10.42.0.30 is the IP of the server.)

Summary

~/Workings/cave/isaac-sim/kit-remote/bin ~/Workings/cave/isaac-sim/kit-remote
I-!$> [2021-08-17 16:58:47,419]=00:58:47= INFO [BifrostClient: Scheduler] {66FFD640} - Successfully set TLS with value 0x212fec0
I-!$> [2021-08-17 16:58:47,419]=00:58:47= INFO [BifrostClient: Scheduler] {667FC640} - Successfully set TLS with value 0x212fec0
I-!$> [2021-08-17 16:58:47,419]=00:58:47= INFO [BifrostClient: Scheduler] {657FA640} - Successfully set TLS with value 0x212fec0
I-!$> [2021-08-17 16:58:47,419]=00:58:47= INFO [BifrostClient: Scheduler] {65FFB640} - Successfully set TLS with value 0x212fec0
I-!$> [2021-08-17 16:58:47,421]=00:58:47= DEBUG [BifrostClient: Interface] {786EF180} - nvbCreateClient( 0x218bea0 )
[indeo3 @ 0x24519c0] [IMGUTILS @ 0x7ffdfdbca2a0] Picture size 0x0 is invalid
[indeo3 @ 0x24519c0] Ignoring invalid width/height values
[indeo3 @ 0x24519c0] [IMGUTILS @ 0x7ffdfdbca2a0] Picture size 0x0 is invalid
[indeo3 @ 0x24519c0] Invalid picture dimensions: 0 x 0!
[2021-08-17 16:58:47,538]=00:58:47= ERROR [LAVCDecoder] {786EF180} - GERONIMO_ERROR 0xC0040003 GERONIMO_LAVCDECODER_AVCODEC_OPEN: avcodec_open2: unable to open codec.
[2021-08-17 16:58:47,540]=00:58:47= ERROR [RemoteGridApp] {786EF180} - DecoderInit failed. 0xc0040003
[2021-08-17 16:58:47,540]=00:58:47= ERROR [OV-Kit-Remote: main] {786EF180} - STARTUP: FAIL: Configure Failed! Exiting.
I-!#>
[2021-08-17 16:58:47,551]=00:58:47= INFO [BifrostClient: Interface] {786EF180} - nvbDestroyClient(). Successfully destroyed NVbClient
~/Workings/cave/isaac-sim/kit-remote

Thanks.

Hi, looks like Isaac Sim on the host is working correctly. Currently, Kit Remote is supported on Ubuntu 18.04 and Windows. If you are running the Kit Remote Client on Ubuntu 20.04, see this post:

1 Like

Thanks for your swift reply! Yes, I use Ubuntu 20.04 as the client, and I manually changed the dependencies to a newer version. I had successfully resolved the issue by using the older version noted in the post.

1 Like