Isaac sim + nucleus path conventions

Is there a step to mount or link “/NVIDIA/Assets/Isaac/2022.2.0/Isaac” in a Nucleus localhost setup such that it is accessible with the shortened “/Isaac” path?

I’m running the Isaac Sim composer tutorials and am issuing commands similar to this: tools/composer/src/ --input */parameters/flying_things_3d.yaml --output */dataset/sample_output --mount ~/composer-workspace --num-scenes

The samples I have found use paths like this:


Which don’t work directly with my installed Nucleus (as configured), however, I can find the appropriate path in my localhost nucleus setup and modify my assets lists or yaml files appropriately as shown:


These simple examples work fine after such a change, but when I attempt to run some pre-configured files (e.g., flying_things_3d.yaml), I start hitting additional missing path errors for assets that are indirectly included in the file via other syntax. It seems fixing these paths manually is against the grain and not the ideal solution.

Hi. The tutorials should work with that path. It looks like you are missing the nucleus flag:
--nucleus-server localhost/NVIDIA/Assets/Isaac/2022.2.0

You can copy this folder to anywhere in your Nucleus server and edit this flag to match the copied path.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.