Issue installing omniverse replicator

I am following the steps given here: to install omniverse replicator on my laptop with a 3080ti GPU. However, on the last step, I am facing issues: .\replicator.insight.bat. This gives the error:

[21.933s] [ext: omni.usd.config-1.0.0] startup
[21.942s] [ext: omni.usd.libs-1.0.0] startup
[69.293s] [ext: omni.kit.async_engine-0.0.0] startup
[72.324s] [ext: omni.assets.plugins-0.0.0] startup
[75.643s] [ext: omni.client-0.1.0] startup
[79.886s] [ext: omni.kit.registry.nucleus-0.0.0] startup
2022-10-21 09:09:47 [69,886ms] [Warning] [omni.client.plugin]  Tick: authentication: Could not resolve host name ""
2022-10-21 09:09:47 [69,886ms] [Warning] [omni.client.plugin]  Tick: authentication: Could not resolve host name ""
2022-10-21 09:09:47 [69,886ms] [Warning] [omni.client.plugin]  Tick: authentication: Could not resolve host name ""
2022-10-21 09:09:47 [69,893ms] [Error] [omni.ext.plugin] Failed to resolve extension dependencies. Failure hints:
        [replicator.insight-0.1.0] dependency: (name: '', tag: '', version: '', exact: 0, optional: 0) can't be satisfied. Available versions:
         (none found)

2022-10-21 09:09:47 [69,895ms] [Error] [omni.ext.plugin] Exiting app because of dependency solver failure...
[80.114s] [ext: omni.kit.registry.nucleus-0.0.0] shutdown
[80.134s] [ext: omni.client-0.1.0] shutdown
2022-10-21 09:09:48 [69,935ms] [Warning] [carb] unloadPlugin: Failed to find a plugin at: c:/users/varda/downloads/replictor/kit/extscore/omni.client/bin/carb.datasource-omniclient.plugin.dll.
[80.152s] [ext: omni.assets.plugins-0.0.0] shutdown
[80.154s] [ext: omni.kit.async_engine-0.0.0] shutdown
[80.166s] [ext: omni.usd.libs-1.0.0] shutdown
[80.234s] [ext: omni.usd.config-1.0.0] shutdown

This issue is not localized to Windows 11 as I am facing it on Ubuntu 2022.04 as well, and it has the same error. Please let me know what can be done to resolve it.

Hello @vardanagarwal16! Did you install the Omninverse Launcher then install Omniverse Code from the Launcher? (Omniverse Launcher > Exchange Tab > Type in “Code”) I ask because, from your attached logs, it looks like it is looking for libraries from the Kit SDK. Let me know if that helps you to move forward or not.

Hi @WendyGram, sorry for the late reply. Installed code from the omniverse launcher as you recommended but the same issue still persists.

I’m getting the same error.

I too have Code installed from the Omniverse Launcher.

kit folder in this context, (unzipped and ran pull_kit_sdk.bat as per instructions) is linked to the target C:\packman-repo\chk\kit-sdk\ which I assume has the latest from kit 104

I can’t find omni.flux anywhere by doing a recursive search for the word flux in these folders:

Windows 11

I see that some flux extensions are in the exts folder of the unzipped structure.
But missing omni.flux.content_library

@mark148 were you able to resolve it?

@vardanagarwal16 ,
not yet. I wonder if anyone has used it yet. Seems like this error should be popping up for anyone trying it.

Closing this issue as there is no need to install replicator separately now. It can be used through omniverse code or isaac sim, both of which are accessible through the launcher.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.