Omniverse can't unpack downloaded extensions

Hi there,

just got hands on the new Isaac Sim 2022 and tried to download some 3D model content packs which I hope will work for Isaac, so I’ve tried the industrial 3d Models pack and the residential 3D models pack

Both start downloading and go straight through the end… then Omniverse tries to create new folders to unpack the archives and fails due to lacking permissions. The parent folder where the stuff gets unpacked is owned by my user and has all standard permissions on Linux to be writable. Under which user is Omniverse started? to I need to assign the folder to some special group or user?

I also tried to launch that appImage thing using sudo but this just wont work. Its kind of an amateur question but still makes me scratching my head if I have overlooked some preparation step during installing Omniverse or of this is just a ‘bug’

Thank you very much

Here is the log file

[2022-07-02 17:38:53.684] [debug] Initializing ov-residential3dpack-01@100.1.1 installer...
[2022-07-02 17:38:53.684] [info]  Fetching ov-residential3dpack-01 information...
[2022-07-02 17:38:54.437] [debug] Enqueue [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] ov-residential3dpack-01.
[2022-07-02 17:38:54.438] [debug] Set current installer [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] ov-residential3dpack-01.
[2022-07-02 17:38:54.467] [debug] Enqueued [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] installer.
[2022-07-02 17:38:54.468] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Preparing https://launcher-prod.s3.us-east-2.amazonaws.com/ov-residential3dpack-01/100.1.1/linux-x86_64/package.zip download to /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1/Residential 3D Models Pack.zip...
[2022-07-02 17:38:54.468] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Preparing downloader for /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1/Residential 3D Models Pack.zip
[2022-07-02 17:38:55.033] [info]  Signed url: https://asset.launcher.omniverse.nvidia.com/ov-residential3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1656819535&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1yZXNpZGVudGlhbDNkcGFjay0wMS8xMDAuMS4xL2xpbnV4LXg4Nl82NC9wYWNrYWdlLnppcCIsIkNvbmRpdGlvbiI6eyJEYXRlTGVzc1RoYW4iOnsiQVdTOkVwb2NoVGltZSI6MTY1NjgxOTUzNX19fV19&Signature=fd~FwfLt7mHUHaMrf3MmKXVcE~xKR7yODX0rqm1mT2lcZ2XZyDYoB1CA0r3UhWbKNh8TTDD1Hf4~WhwQ0-ISMbeaebRWikEwEIxnA30bj~kh7~hQt4sz7zLuTN4z-ErypQgfj7sM6b4Gcj7V~KtsssdMNkWvZ6GeDqVTBqpO8LcjNwjTBAgNkgwIcU7fw0-jlYuwS-lxSwkDnEWA6j1CRPXnZlqRdicgWqvgpzpzjvLAZZ8CJPiAZIoSUQL1fsbUSidD38YMWawaA5aF85-dxOG6qRL6iqJaRRt7lmWD9cvishNuSBson~YOhi8qRR-tcxhAz19KeezhjJa7s1Tr1Q__&Key-Pair-Id=K13PD0MHC2KFRP
[2022-07-02 17:38:55.034] [info]  [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Calculating package size for https://asset.launcher.omniverse.nvidia.com/ov-residential3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1656819535&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1yZXNpZGVudGlhbDNkcGFjay0wMS8xMDAuMS4xL2xpbnV4LXg4Nl82NC9wYWNrYWdlLnppcCIsIkNvbmRpdGlvbiI6eyJEYXRlTGVzc1RoYW4iOnsiQVdTOkVwb2NoVGltZSI6MTY1NjgxOTUzNX19fV19&Signature=fd~FwfLt7mHUHaMrf3MmKXVcE~xKR7yODX0rqm1mT2lcZ2XZyDYoB1CA0r3UhWbKNh8TTDD1Hf4~WhwQ0-ISMbeaebRWikEwEIxnA30bj~kh7~hQt4sz7zLuTN4z-ErypQgfj7sM6b4Gcj7V~KtsssdMNkWvZ6GeDqVTBqpO8LcjNwjTBAgNkgwIcU7fw0-jlYuwS-lxSwkDnEWA6j1CRPXnZlqRdicgWqvgpzpzjvLAZZ8CJPiAZIoSUQL1fsbUSidD38YMWawaA5aF85-dxOG6qRL6iqJaRRt7lmWD9cvishNuSBson~YOhi8qRR-tcxhAz19KeezhjJa7s1Tr1Q__&Key-Pair-Id=K13PD0MHC2KFRP...
[2022-07-02 17:38:55.130] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] ov-residential3dpack-01@100.1.1: 
[2022-07-02 17:38:55.131] [debug]   Downloaded: 0
[2022-07-02 17:38:55.131] [debug]   Total: 22887498052
[2022-07-02 17:38:55.132] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Start ov-residential3dpack-01@100.1.1 download
[2022-07-02 17:38:55.132] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Downloading https://asset.launcher.omniverse.nvidia.com/ov-residential3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1656819535&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1yZXNpZGVudGlhbDNkcGFjay0wMS8xMDAuMS4xL2xpbnV4LXg4Nl82NC9wYWNrYWdlLnppcCIsIkNvbmRpdGlvbiI6eyJEYXRlTGVzc1RoYW4iOnsiQVdTOkVwb2NoVGltZSI6MTY1NjgxOTUzNX19fV19&Signature=fd~FwfLt7mHUHaMrf3MmKXVcE~xKR7yODX0rqm1mT2lcZ2XZyDYoB1CA0r3UhWbKNh8TTDD1Hf4~WhwQ0-ISMbeaebRWikEwEIxnA30bj~kh7~hQt4sz7zLuTN4z-ErypQgfj7sM6b4Gcj7V~KtsssdMNkWvZ6GeDqVTBqpO8LcjNwjTBAgNkgwIcU7fw0-jlYuwS-lxSwkDnEWA6j1CRPXnZlqRdicgWqvgpzpzjvLAZZ8CJPiAZIoSUQL1fsbUSidD38YMWawaA5aF85-dxOG6qRL6iqJaRRt7lmWD9cvishNuSBson~YOhi8qRR-tcxhAz19KeezhjJa7s1Tr1Q__&Key-Pair-Id=K13PD0MHC2KFRP...
[2022-07-02 17:38:55.198] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Save https://asset.launcher.omniverse.nvidia.com/ov-residential3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1656819535&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1yZXNpZGVudGlhbDNkcGFjay0wMS8xMDAuMS4xL2xpbnV4LXg4Nl82NC9wYWNrYWdlLnppcCIsIkNvbmRpdGlvbiI6eyJEYXRlTGVzc1RoYW4iOnsiQVdTOkVwb2NoVGltZSI6MTY1NjgxOTUzNX19fV19&Signature=fd~FwfLt7mHUHaMrf3MmKXVcE~xKR7yODX0rqm1mT2lcZ2XZyDYoB1CA0r3UhWbKNh8TTDD1Hf4~WhwQ0-ISMbeaebRWikEwEIxnA30bj~kh7~hQt4sz7zLuTN4z-ErypQgfj7sM6b4Gcj7V~KtsssdMNkWvZ6GeDqVTBqpO8LcjNwjTBAgNkgwIcU7fw0-jlYuwS-lxSwkDnEWA6j1CRPXnZlqRdicgWqvgpzpzjvLAZZ8CJPiAZIoSUQL1fsbUSidD38YMWawaA5aF85-dxOG6qRL6iqJaRRt7lmWD9cvishNuSBson~YOhi8qRR-tcxhAz19KeezhjJa7s1Tr1Q__&Key-Pair-Id=K13PD0MHC2KFRP to /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1/Residential 3D Models Pack.zip
[2022-07-02 18:37:33.043] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Extracting ov-residential3dpack-01@100.1.1 to /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1...
[2022-07-02 18:37:33.049] [debug] Dequeue [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] ov-residential3dpack-01.
[2022-07-02 18:37:33.049] [debug] Reset current installer.
[2022-07-02 18:37:33.050] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Removing the artifact path /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1/Residential 3D Models Pack.zip due to an error.
[2022-07-02 18:37:34.679] [debug] [8c3c0c56-56e9-4f9b-ac0e-dbc98d74092e] Removing the installation path /home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1 due to an error.
[2022-07-02 18:37:34.680] [error] Error: EACCES: permission denied, mkdir '/home/schulze/Downloads/content/ov-residential3dpack-01-100.1.1/Appliances/Dishwashers/'
[2022-07-03 00:30:53.803] [info]  Crash dumps directory: /home/schulze/.config/omniverse-launcher/Crashpad
[2022-07-03 00:30:54.062] [info]  Omniverse Launcher 1.5.5 (production)
[2022-07-03 00:30:54.062] [info]  Argv: /tmp/.mount_omniveE5IwNg/omniverse-launcher --no-sandbox
[2022-07-03 00:30:54.198] [debug] Running "/data/simulators/isaac/native/ldpath/cache-2022.1.1/System Monitor/omni-system-monitor"
[2022-07-03 00:30:54.206] [debug] Reset current installer.
[2022-07-03 00:30:54.803] [info]  Logged in.

1 Like

Just ran into the same issue:

Even changing to a different folder did not resolve the problem although omniverse seems to run on the correct user.

21:37:26.827 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Start ov-industrial3dpack-01@100.1.1 download
21:37:26.828 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Downloading https://asset.launcher.omniverse.nvidia.com/ov-industrial3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1657093047&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1pbmR1c3RyaWFsM2RwYWNrLTAxLzEwMC4xLjEvbGludXgteDg2XzY0L3BhY2thZ2UuemlwIiwiQ29uZGl0aW9uIjp7IkRhdGVMZXNzVGhhbiI6eyJBV1M6RXBvY2hUaW1lIjoxNjU3MDkzMDQ3fX19XX0_&Signature=L27DpGtDbPmy-FIUWmNU97h3fuzrDNjO~74fFZxe72uYrua5J5lwNlH9MYO-6vxMQBAIjiNPnACJxLRm1cf4rVzh8jubc-dMsPpJVQWtBesm-4Rk0d9VSmxRU2EUnVctHr5qDCKy57vPksIKNdgeYEEUeO19f-hhei7MSz5M4~1pXdf81anRzDoqkDdlm8YTn9iRgQwL5X0nFa~QTZEzjJe2YxK~JNckKDkEqv8KdqOaT4bbyr4yxsJCXVkMXrSErz6y~q4nfRzytEIjOKuOcZ-PL8ilK2RMFVzYi-dcN3CjuZoP2B95Hcignf9ivn7Wpa~thznFI1sa~OXl2v~hcQ__&Key-Pair-Id=K13PD0MHC2KFRP...
21:37:26.940 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Save https://asset.launcher.omniverse.nvidia.com/ov-industrial3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1657093047&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1pbmR1c3RyaWFsM2RwYWNrLTAxLzEwMC4xLjEvbGludXgteDg2XzY0L3BhY2thZ2UuemlwIiwiQ29uZGl0aW9uIjp7IkRhdGVMZXNzVGhhbiI6eyJBV1M6RXBvY2hUaW1lIjoxNjU3MDkzMDQ3fX19XX0_&Signature=L27DpGtDbPmy-FIUWmNU97h3fuzrDNjO~74fFZxe72uYrua5J5lwNlH9MYO-6vxMQBAIjiNPnACJxLRm1cf4rVzh8jubc-dMsPpJVQWtBesm-4Rk0d9VSmxRU2EUnVctHr5qDCKy57vPksIKNdgeYEEUeO19f-hhei7MSz5M4~1pXdf81anRzDoqkDdlm8YTn9iRgQwL5X0nFa~QTZEzjJe2YxK~JNckKDkEqv8KdqOaT4bbyr4yxsJCXVkMXrSErz6y~q4nfRzytEIjOKuOcZ-PL8ilK2RMFVzYi-dcN3CjuZoP2B95Hcignf9ivn7Wpa~thznFI1sa~OXl2v~hcQ__&Key-Pair-Id=K13PD0MHC2KFRP to /home/stefan/temp/NvidiaDownloads/ov-industrial3dpack-01-100.1.1/Industrial 3D Models Pack.zip
21:38:40.828 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Extracting ov-industrial3dpack-01@100.1.1 to /home/stefan/temp/NvidiaDownloads/ov-industrial3dpack-01-100.1.1...
21:38:40.847 › Dequeue [a4c8e20a-5938-46f2-8ad7-a66104a6c220] ov-industrial3dpack-01.
21:38:40.848 › Reset current installer.
21:38:40.849 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Removing the artifact path /home/stefan/temp/NvidiaDownloads/ov-industrial3dpack-01-100.1.1/Industrial 3D Models Pack.zip due to an error.
21:38:41.040 › [a4c8e20a-5938-46f2-8ad7-a66104a6c220] Removing the installation path /home/stefan/temp/NvidiaDownloads/ov-industrial3dpack-01-100.1.1 due to an error.
21:38:41.042 › Error: EACCES: permission denied, mkdir '/home/stefan/temp/NvidiaDownloads/ov-industrial3dpack-01-100.1.1/Buildings/Warehouse/'

even if the folder has the following user rights:

drwxrwxrwx  2 stefan stefan 4,0K  5. Jul 21:34 NvidiaDownloads

Same issue here. Any luck guys?
"Error occurred during installation of vMaterials 2 Pack: EACCES: permission denied, open ‘/home/shan/Omniverse/installtion/CONTENT/ov-vmats2pack-01-100.1.1/Carpet/Carpet_Woven.mdl’

Same issue here on Ubuntu 22.04. Any solution?

I have the same issue, no matter the OS version, the problem comes from the archive I believe, that is stored somewhere on NVIDIAs AWS-account.
Anyway I found a solution, but that was not a quick fix, because I had to modify all the archives after I downloaded them manually.
Step 1: Start the download for the content pack, you are looking for and cancel it after it has started

Step 2: locate the launcher.log file in ~/.nvidia-omniverse/ and scroll to the bottom

Step 3: locate the line that contains a signed url for the content-pack you wanted to download

[2022-08-23 06:20:21.886] [debug] [8b73af23-64b1-4312-a48b-2e5ffcbff20f] Save https://asset.launcher.omniverse.nvidia.com/ov-industrial3dpack-01/100.1.1/linux-x86_64/package.zip?Expires=1661304022&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS9vdi1pbmR1c3RyaWFsM2RwYWNrLTAxLzEwMC4xLjEvbGludXgteDg2XzY0L3BhY2thZ2UuemlwIiwiQ29uZGl0aW9uIjp7IkRhdGVMZXNzVGhhbiI6eyJBV1M6RXBvY2hUaW1lIjoxNjYxMzA0MDIyfX19XX0_&Signature=AshOl53DUEPKr0ECzZ6-DiCbuPBGTsF3rYh1oJRTysZ6vHFdIjQgknVu0huhemDQMpeyVXR05kMRPwB4qFKBh9z3vpi9vxs66m47XB58UpR0r5UJ8ehykF4-Fb0VXEBLzDSvT6gI-PIHhZYd7R269-yEI9W-VUFKKJgU0ROU2n9HILlxQ~OA~Hph6KcPA9~odrOZLVjgx-P8c4-ZCqrdWL2ouTsReR4jLm71~0hgPjn789ATxifMAj20AKkn8tofD7ofLrm~693F8CLem7BVGAiB0uK2W3F7qbE9CTprX-a4OMbBfsrt693gp4dXUjqQcQAyB197xpOfbWKYzfp8KA__&Key-Pair-Id=K13PD0MHC2KFRP to /home/pc/Downloads/ov-industrial3dpack-01-100.1.1/Industrial 3D Models Pack.zip

Step 4: copy the url to your browser and download the file that way
Step 5: after the download has finished basically do what the log says and create a folder in the Downloads directory names after the model pack. For me that was “ov-industrial3dpack-01-100.1.1”

Step 6: extract the content of the package.zip file, you got from the signed url into that created folder
Here is, why this problem even exists:
Some of these files have interesting permissions(notice the “no access” tag for the owner):
Screenshot from 2022-08-23 16-02-04

Step 7: to solve this you can go into the permissions of the parent folder you created manually, by default this should be set to “Create and delete files”, with this setting just click on “Change Permissions for Enclosed Files…”. That should do the trick for all the files that are living in this archive.

Step 8(last step): with everything setup restart the download in the Omniverse-launcher, if all permissions are setup correctly the process should run smoothly

I have to admit, I have no idea if the second download(step 8) is necessary or not and I did it just for safety measures, just in case, that the “installer” or whatever copies this files to nucleus or any other directory that matters.

1 Like

Thanks! It works for me.

BTW, the omniverse can be launched by executing the AppImage file directly from terminal, so that there is no need to inspect the log file, which will be a little bit more convenient

I’m getting this error too. Wondering how anyone is able to get this content at the moment without the hack explained here? I heard maybe we need nucleus installed for this to work, but that didn’t do it for me either. It would be great if someone from nvidia could address this thread.

Have you solved it? If you haven’t, you can download it from the following link. Omniverse