How can I uninstall Omniverse?

I tried uninstalling what I could via the Launcher and via Windows then, finally, I went and manually deleted all the files from every folder I used. After I reinstalled the launcher and tried to setup a collaboration space it still remembered the paths I used from my previous installation, meaning uninstall did nothing but delete a few files and left who knows what else still remaining on my system

So, how do I uninstall Omniverse without formatting my harddrive? I want to start everything from scratch and see if Omniverse actually works from a clean install… but first I need a clean install which is impossible without uninstalling the existing content… which seems impossible to do also. Can anyone offer me some advice, please?

I will consider your advice valid if i go to add my first collaboration server and it does NOT pop up “Localhost” as my first server name and show me a path on my D drive by default. Also, when I install the Launcher it would be nice if it asks me WHERE to store my files to rather than telling me “Please restart to run the updated version” instead of asking me where to install stuff to.

Thanks in advance

Hello! We are sorry to hear of your uninstall issues with Omniverse. Please download the following tool and Run As Administrator. Hope this helps!
https://docs.omniverse.nvidia.com/prod_launcher/prod_utilities/cleanup-tool.html

Hi. Thanks for the assist but unfortunately that didn’t work at all. :(

As soon as I ran that it just reopend the launcher immediately and tried to reinstall the nucleus… then failed.
I uninstalled the launcher again and ran the tool again… this time it just spits out errors.
I reinstall the launcher and it still remembers my old install path and, immediately upon starting it starts downloading the nucleus again. It tries to install and fails. I close and uninstall, reinstall, it still knows my old paths, immediately starts downloading Nucleus AGAIN, installs, fails. Close the launcher, open the launcher, it automatically starts downloading the Nucleus again

[insert infinite loop here]


@mybadstudios -
Can you run systeminfo and tell me what windows language/locale you are using?

Here you go. Hope this helps:

EDIT: Earlier today I did a search through my registry and deleted everything I could find relating to Omniverse (after deleting everything again). A few entries were not delete-able, though. Anyway, I also downloaded the latest Omniverse Launcher and reinstalled using that.

In an earlier version I reported a bug where the launcher would demand my content be in the default location on the C drive and even though I changed it to my D drive which has far more space, it jus kept on defaulting back to the default path you set. You said that in a very near future you would fix that problem since you were able to reproduce it and I assumed that was done already… however, the launcher no longer forces me to reselect my install path each time and when I go into settings the path is fine everywhere… until I try to install something new, then it still defaults to the C: path you hardcoded.

So, just to get things rolling again, I eventually changed my paths to my C: (so I now have like 100Gb space for my Drive/Cache to share with whatever else I do with my PC, even though you warn this could easily require Terabytes). My hope was that since I restored all settings to default before uninstalling and manually cleaning out the registry, hopefully NOW when I install the launcher it will ask me my paths again during installation…

Instead it seems I found a bug in the Launcher instead. First off, installation never asked me to pick the paths for the library and cache etc. It just used what I had before. Clearly uninstall did not do a good enough job of uninstalling. Next, though, I decided to reinstall all the elements I had deleted and found that as soon as I start downloading a new one, rather than adding it to the queue it starts downloading immediately and pauses the other stuff being downloaded. Once downloading and installation of the latest item is complete the other items stay paused and thus I cannot download the rest. (Or maybe it was just Machinema?)

Closing Omniverse and restarting made it think it is still busy with Machinema and so it started to download the entire thing again. I tried to pause the download but pausing did nothing… until I spam clicked it to get the “Really stop?” button come up… which also required spam clicking to make it stop downloading the already installed app.

I will check later on if the other packages at least work now even if without a Nucleus. Can Drive work without being signed in to a server? Can I thus export from Character Creator 3 and import into UE5? If so I guess I can live without Nucleus and just insist the people who collaborate with me do so via wifi, adding my machine to their File Explorer shortcuts to load/save content directly onto/from my PC. Obviously, though, this is far from ideal but Nucleus does NOT want to play nice and even the Launcher clearly has difficulties uninstalling itself or just starting a fresh install when I run the installer. Sacrifices seem to be the order of the day.

@mybadstudios
I see you’re hitting an issue when running the cleanup tool.

The path listed in the error is c:\Users\xbox\\AddData\\Local\\ov\pkg\\cache-2.0.1\\System Monitor. Notice the single backslashes vs the double backslashes? We’ve seen this issue before with this specific path c:\Users\xbox.

Is your computer username xbox? Does c:\users\xbox exist?

yeah. my Xbox Live is xbox @ mybadstudios.com so when I installed Windows and gave it my Xbox live email address it created my username as “xbox”. A user named xbox…never let it be said that I am not unique 😅

So, anyway, moving on… what do I do about those slashes? I just run the executable and it gets it’s paths from somewhere I don’t know. Is this something I can/need to change somewhere or…?

OH!!! So THAT is where it gets the \U from that it is complaining about!? C:\Users ! Guh! I was wondering where it got that from… Anyway, I digress. What do I do?

I am thinking I need to revise my question/subject now, though, as I just reinstalled everything and don’t really want to uninstall everything and then redownload everything again… I would like to know how to uninstall/reinstall Nucleus or somehow get it to authorize me on my own computer. Maybe the slashes issue can help with that, still?

Yeah, let’s see if you can fix the paths in our config files. Look in c:\users\xbox\.nvidia-omniverse\config. Open each omniverse.toml you find in the root and all subdirectories and change any of the c:\users\xbox to c:\\users\\xbox.

Once they are all fixed you can then try uninstalling Nucleus from the Launcher and then reinstall it.

1 Like

I found that there were a bunch of folders with .toml files pointing to that invalid path. The folders all seemed related to Collaboration (which isn’t installed) so I just deleted all of them completely and then tried to install it again. Worked like a charm.

Now I just want to go see if it installed my data path to my C: with almost no space left or my D: with plenty of space. So while I have the collaboration tab open I notice there is an NVIDIA folder with a lock on it. I click on it just to see what I can see and I see the URL is http://localhost:8080/omniverse://127.0.0.1/NVIDEA
That URL looks a bit… shall we say “Off”? Is that correct the way it appears?

Anyway, progress! Thanks :)

Okay… so it seems I am all set. Solution was to delete all the old settings files and letting it recreate them from scratch.

This brings up one point that I mentioned before but with my limited monthly cap, this is an issue for me… Deleting Nucleus didn’t remove all settings files but trying to install it caused it to download each time I tried. Download, install, fail, all files gone except the settings files that caused the problem. I see the Collaboration Workstation is about 200Mb in size but I spent somewhere around 2Gb downloading it this week since it doesn’t seem to be stored anywhere after being downloaded. Considering I only have a 50Gb cap, spending 4% of that on a 200Mb download rather sucks… quite a lot. :( …and if it did a complete uninstall after failing to install and then deleting itself the problem would have been fixed for me.

I guess the main problem is “Why did it store the paths so broken?” but at least now I know what the problem is and where to go to fix it so I am all good again for now. Thanks very much for your assistance.

1 Like

Thanks for following up on this @mybadstudios! Glad you’re up and running.

1 Like

This helped me also. When I had to change my user name in Win 10 to remove a space that was not appreciated by some coding solutions Omniverse kept the old user name in its .toml config files. Audio2Face would not install until I manually changed the config files to have the new user name.