Blender branch installation freeze

I tried to restart omniverse but it w ill redownload blender ,installation can‘t finish 。 please help me

Hello @zelda007! Could you send me a copy of your Omniverse Launcher logs? You can find them here: C:\Users\<USERNAME>\.nvidia-omniverse\logs\launcher Your logs will hopefully have the information needed to identify the issue.

You can also try running the Omniverse Cleanup-Tool to see if that helps!

Thank you for your reply ,I’ve tried the cleanup tool and still have the same problem,here is my logs
launcher.log (15.3 KB)

Hello @zelda007. It looks like you’re installing an older version (3.2) of the Blender release. Can you please try installing the most recent version on the launcher (3.4) and see if that helps? Also, please be sure you don’t have an open Blender session running while doing the install.

It happens to me the same.
I can’t install it and remains frozen:

I took care of don’t have opened any Blender instance during the installation and I have installed the latest Blender version.
What can I do?

I have executed the “cleaner” and uninstalled all according to what it does and after that, I’ve restarted again to install all…But no luck.