Issue with Mellanox ConnectX-5 100Gbit Card and Driver Installation

Hello Nvidia community,

I hope this message finds you well. I am currently facing an issue with my Mellanox ConnectX-5 100Gbit network card, and I’m seeking assistance from the community to resolve it.

Problem Description:
My Mellanox ConnectX-5 card does not seem to be functioning at 100Gbit as expected. To address this, I attempted to install the drivers following the official Mellanox documentation. However, I encountered difficulties during the installation process.

Installation Console Log:

inets@inets-7010:~/mellanox/MLNX_OFED_LINUX-5.8-4.1.5.0-ubuntu22.04-x86_64$ sudo ./mlnxofedinstall --fw-image-dir /tmp/my_fw_bin_files
[sudo] password for inets:
Logs dir: /tmp/MLNX_OFED_LINUX.9520.logs
General log file: /tmp/MLNX_OFED_LINUX.9520.logs/general.log

Below is the list of MLNX_OFED_LINUX packages that you have chosen
(some may have been added by the installer due to package dependencies):

ofed-scripts
mlnx-tools
mlnx-ofed-kernel-utils
mlnx-ofed-kernel-dkms
iser-dkms
isert-dkms
srp-dkms
rdma-core
libibverbs1
ibverbs-utils
ibverbs-providers
libibverbs-dev
libibverbs1-dbg
libibumad3
libibumad-dev
ibacm
librdmacm1
rdmacm-utils
librdmacm-dev
mstflint
ibdump
libibmad5
libibmad-dev
libopensm
opensm
opensm-doc
libopensm-devel
libibnetdisc5
infiniband-diags
mft
kernel-mft-dkms
perftest
ibutils2
dump-pr
ibsim
ibsim-doc
ucx
sharp
hcoll
knem-dkms
knem
openmpi
mpitests
libdapl2
dapl2-utils
libdapl-dev
dpcp
srptools
mlnx-ethtool
mlnx-iproute2
rshim

This program will install the MLNX_OFED_LINUX package on your machine.
Note that all other Mellanox, OEM, OFED, RDMA or Distribution IB packages will be removed.
Those packages are removed due to conflicts with MLNX_OFED_LINUX, do not reinstall them.

Do you want to continue?[y/N]:y

Checking SW Requirements…

Removing old packages…
Uninstalling the previous version of MLNX_OFED_LINUX
Installing new packages
Installing ofed-scripts-5.8…
Installing mlnx-tools-5.8.0…
Installing mlnx-ofed-kernel-utils-5.8…
Installing mlnx-ofed-kernel-dkms-5.8…
Installing iser-dkms-5.8…
Installing isert-dkms-5.8…
Installing srp-dkms-5.8…
Failed to install srp-dkms DEB
Collecting debug info…
See /tmp/MLNX_OFED_LINUX.9520.logs/srp-dkms.debinstall.log

I am reaching out to the community for guidance on resolving this issue. Any insights, suggestions, or similar experiences would be greatly appreciated.

I will attach the srp-dkms.debinstall.log:
mlnx-ofed-kernel-dkms.debinstall.log (3.5 KB)

System Information:

OS: Ubuntu 22.04

Thanks for your assistance.

Best regards,
Oliver