Issues connecting jupyter notebook to Isaac sim

Hey all,

Im currently trying to get myself set up to do some RL training of a jetbot in Issac sim to then use the model on a real jetbot.

Im am working through this course which has been a good start and I’m trying to recreate parts of it in my own server rather than the one provided for the course so I can refer back to it.

This is where I’ve got my issues I have Isaac sim set up on an AWS instance as described in this documentation (due to a lack of GPU hardware) and I can connecting to it using Omniverse Streaming Client.

I have jupyter notebooks working thanks to this documentation

However when I try to run the hello_word.ipynb it doesn’t run because I don’t have a local nucleus server set up, I’ve tried to find a guide to setting this up on AWS via command line bur cant find anything.

I have also tried to copy the courses approach and use the isaac magic commands

%run -i 'scripts/'
%isaac --reset --status

I copied the over to my instance and it shows me the correct IP and that the server is ready but then it errors when sending commands.

ExceptionPexpect: The command was not found or was not executable: telnet.

I’ve tried to search and i find a few articles that look like they will be useful but when I follow the links they are dead.

In general I’m just struggling to get a working environment set up that after the course I can continue to work with. Im hoping there is something stupid I’ve missed and someone can tell me to just click the ‘make it work’ button that I’ve missed.

Hi @david.lumley - Can you share the log file to debug the error you are getting?

Thanks for the response.

What log file do you want?

If I’m honest I don’t think I’ve got it set up properly and really just want pointing at a set of instructions to allow me to have Jupyter notebook talk to Isaac sim.

Hi. Currently, there are issues running the Jupyter Notebook in our container.
I recommend running Isaac Sim from the Launcher with Nucleus installed to run the Jupyter Notebooks.
On AWS, you can try running Isaac Sim in a virtual Workstation.