Can't get AWS version of Issac Sim to work

Followed the setup instruction on the user guide, got to the step of launching the docker container with this:

sudo docker run --gpus all -e “ACCEPT_EULA=Y” --rm -p 47995-48012:47995-48012/udp -p 47995-48012:47995-48012/tcp -p 49000-49007:49000-49007/tcp -p 49000-49007:49000-49007/udp

Then it had a number of error with the last message printed and stuck here.

2021-01-04 21:25:36 [44,583ms] [Info] [omni.usd] ResyncedPaths: /World/def

Does the user guide need to be updated?


What is the error that is printed before the last line?
It should be fine if the error is listed here.

Does the remote streaming still work?

No the remote streaming also does not work.

Here is an update, I tried the terraform script of launching the instances, and was able to connect a windows client to the server successfully.

You could try using the –network=host flag instead if there are issues connecting using the Kit Remote app. See Problem connecting to Docker container

I have another issue, to follow the tutorial, I need to create a “Isaac” folder under the root of the Nucleus server, but I can’t do that. I can create directory under the “user” folder, but not at the root level. What am I doing wrong?

You can create the “Isaac” folder in the Isaac Sim app instead. Follow the steps here.

Hmm I must be doing something wrong, I did follow the instruction and tried to create the isaac folder in Isaac Sim app (remote client running on windows), it didn’t work.


An alternative solution is to give permission to the current user from Nucleus server. You can check this post

When running as container, you can set the omniverse username with:

$ sudo docker run --gpus all -e "ACCEPT_EULA=Y" -e "OMNI_USER=omniverse" -e "OMNI_PASS=omniverse" --rm --network=host

You can also use the alternative solution mentioned. The default username when using docker is



Ok, I added the dockeruser to the gm group, now I can create the folder in Issac Sim app, however, I can’t upload any asset from the Nucleus Web interface, I see the folder, but can’t upload any file or create any sub folder, or see the permission of the folder.

Try login to the Nucleus web using the omniverse/omniverse as the username/password. This user should be able to verify that the permissions for the folders are correct.

I tried the mount option and it worked. I am good for now.

However, I got the following error message, when I am trying to connect to the JetBot example, the “w”, “a”, “d”… key didn’t work, with the following error message: DcSetDofVelocityTarget:Invalid or Dexpired DOF Handle.

What does that mean?

I had the same problem, it seemed to be something about the file version. Following this advice solved it for me:

1 Like

Hi hcreal,

as Oliver mentioned, you have the old assets, please get the latest.