Issues on flashing Linux on NVMe not EMMC

I was wondering if you have ever encountered any issues while flashing Linux on the Nvidia Jetson by using Nvidia SDK manager.

I have not had any problems when flashing Linux on the EMMC memory, which is installed internally.
However, when I try to flash Linux on the externally mounted NVMe memory, I receive an error from the SDK manager.
The process proceeds to about 96%, but when the Jetson reboots to complete flashing, it only displays a blinking underscore on Jetson, and prints failed message on host PC.

I tried Jetpack 5.1 version and SDK version is 1.9.2.
Ubuntu 18.04 is installed on Host PC.
I’m sure that there is no physical connection issue between my Xavier AGX and NVMe because I checked it in Linux environment installed on EMMC(default storage).


can you put the error message and flashing log here?

What do you mean with no physical connection?

I’m sorry that I missed a word “issue”. No physical connection issue between Xavier and NVMe.
I’ve corrected the sentence I wrote.

And I attached logs that were generated from SDK manager. I hope that it helps to solve this situation.
SDKM_logs_JetPack_5.1_(rev._1) (211.0 KB)

I have a thing that I can share with you.
I tried to flash using Jetpack4.6.3 and there was no problem. Of course, I selected NVMe option.


can you try if JetPack 5.1.1 also results in the same error?

I already tried 5.1.1 because it’s the latest version. Unfortunately, I didn’t save logs on it.
As far as I remember, I believe that it printed same error.


are you using the official AGX Xavier DevKit?
Please see if the following options work:

  1. Make sure your SSD is pre-formatted as ext4 before flashing.
  2. Use a real Ubuntu 18.04/20.04 host PC in case it’s a VM.
  3. Try the latest JetPack 5.1.1

If all of the above do not work, we’ll see if we can re-produce this issue on our side.

I’m using AGX Xavier DevKit.

  1. I tried with formatted SSD as ext4 before posting the situation.
    I flashed on EMMC first, and I opened “Disks” app which is basically installed on Ubuntu, and I formatted the SSD.
    And I tired to flash on NVMe using 5.1.1, but it failed.

  2. I didn’t use VM. I used pure Ubuntu 18.04 for it.

If possible, I think that’s a good way for you to re-produce the issue on your side like you said.

mount.nfs: access denied by server while mounting [fc00:1:1:0::1]:/home/jusungha/nvidia/nvidia_sdk/JetPack_5.1_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/rootfs

The error log is from this NFS setting on your host PC. It may not reproduce on our side.

Please check /etc/exports first.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.