Issues with lighting exporting entire large scale project from UE5.1 to Omniverse

Hi there. I am trying to export a large scale scene from Unreal Engine 5.1 to omniverse using USD.
The export is going great and i am impressed, however it seems that the lighting is very different. almost as if in omniverse there is no GI.
Does anyone know how to fix it?
Unreal: https://i.imgur.com/3wmUIoK.jpeg
Omniverse: https://i.imgur.com/T0aJDHV.jpeg

@fasttrackstudio looks like you have a few skylights up above. it could be the glass material that didn’t quite translate properly. can you try hiding the glass or have it not cast shadow to see if it changes anything for you? i tend to keep my materials simple when using any connector to increase the chances of materials not breaking.

p.s. is it Emiel? if so, a fan of your tutorials!

also, switching to RTX-Interactive would generally help producing more accurate lighting (assuming if it’s not a material problem) at the cost of some performance.

The windows do not have actual glass in them. all lights seem to be working. it is just that where there is shadow it is like pitch black as if no light bounces. also the post effect controls are not working anymore :/ this happens on all modes from real-time to raytracing.

And yeah it is me :) glad you like the courses ;)

how was the environment light done in UE, do you have a dome light or skylight setup? there are some controls over GI bounces in the OV render setting, but was trying to see if there’s any issue pertaining to the connector first.

also, none of the post effects works, even with the checkboxes turned on next to each post effect rollout?

other settings to look for is potentially the camera and the fog/atmospherics in OV, which is found inside of ‘common’ render setting.

Sadly these are also not the issue since i mostly need the tonemapping which does not have the checkbox. I am not sure what the issue is but i think it is not just a missed setting

also, i do get the domelight to work outside but it seems it does not affect the inside in any way

I managed to get things to somewhat work. It is still not super similar to Unreal but i ended up placing a dome light and boosting the diffuse multiplier by ALOT. this is okay for the interior scene but since i also have an exterior as soon as i want to go outside i would need to change the settings.
Here is the end result with some photo editing

1 Like

In most cases, adding a dome light and turning off Auto Exposure can fix the issue. We planned to add the dome light by default when exporting an unreal map

These are the settings you need to boost and soften out secondary indirect or bounced lighting. We have two methods. Global Illumination and Ambient Occlusion. Both of these can be adjusted independantly. By default GI is set to 1.0 and AO Ambient Light is set to 0.0. But you can turn this to 1.0 to boost additional fill light. GI is a little more accurate and modern, but can have some issues. AO light is more of a default fill light, and not as photo realistic, but it works very well to fill in dark areas.

image

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.