It sticked when I tried to install ubuntu 22.04 for Bluefield2 from terminal or sdkmanager

Hi! I’m trying to ssh into my BlueField2 card and install a full Ubuntu OS to my BlueField2 card. I tried two methods, but neither of them succeeded:

1. use the terminal, I got stuck after getting the below information:

bfb-install --rshim /dev/rshim0/ --bfb --config bf.cfg

Pushing bfb + cfg
1.11GiB 0:12:45 [1.48MiB/s] [ <=> ]
Collecting BlueField booting status. Press Ctrl+C to stop…

2. use SDK manager, I noticed that it uses the same command as what I used in the terminal, and it has some more information as below:

04:37:36 ERROR: Flash BlueField OS - flash: ./ 105: pci_id: not found
04:37:36 ERROR: Flash BlueField OS - flash: mlxprivhost: error: Please provide a command to execute, check the help menu
04:37:36 ERROR: Flash BlueField OS - flash: mlxprivhost: error: Please provide a command to execute, check the help menu
04:37:36 ERROR: Flash BlueField OS - flash: ./ 117: [: =: unexpected operator

and then it stuck too!!!

I really need some help. I can ping and, but I can’t ping successfully.
I don’t think is preconfigured successfully on my machine.

Is anyone can help me ssh into this Bluefield2 DPU? I studied all night. SO SAD

Address HWtype HWaddress Flags Mask Iface (incomplete) virbr0 (incomplete) tmfifo_net0 (incomplete) tmfifo_net0
engs-24076.ddns.eng.ox. ether ec:b1:d7:33:12:41 C enp36s0f1
enginesnas2.ddns.eng.ox ether d8:50:e6:4d:bc:ea C enp36s0f1
_gateway ether ec:c8:82:4d:19:44 C enp36s0f1 (incomplete) tmfifo_net0
engs-25028.ddns.eng.ox. ether f4:8e:38:ad:e4:f0 C enp36s0f1

Hi @ziji.chen ,

It’s possible that it’s not a “prod” card. There are ES cards are signed with a development key rather than a production key. These cards require different BFBs, which are not published.

Did you receive the card as an ES? If you can share its PSID, I could check it.
Please note that in this case, since the BFB is not published, the request must go through a support ticket channel, based on your entitlement.


Hi, thank you for your reply. How can I confirm is it an ES card?


I had the exact same issue. The solution was to go to the UEFI BIOS configuration (default password is bluefield) and disable secure boot mode and set the BlueField mode to a valid configuration.

See Step 04.04: Ensure that the BlueField Mode is correctly set in the UEFI configuration in the following post

How to update BlueField-2 DPU with the DOCA 2.2.0 firmware image

Elvis Dowson

Hi, Elvis! Thank you for your reply. My situation is that the machine always freeze when:

bfb-install --rshim /dev/rshim0/ --bfb DOCA_v1.2.1_BlueField_OS_Ubuntu_20.04-5.4.0-1023-bluefield-5.5- --config bf.cfg
Pushing bfb + cfg
705MiB 0:07:51 [1.50MiB/s] [ <=> ]
Collecting BlueField booting status. Press Ctrl+C to stop…

Have you ever met that?


Just interrupt the boot process, disable UEFI secure boot and set the BlueField mode as described in the link I provided earlier.

This should allow you to upgrade the OS image to 2.2.0 and subsequent firmware updates.


The root cause for bricking a BF2-DPU may be related to:

a. old signing keys installed in the old BF2-DPU UEFI BIOS, which prevent a newer DOCA v.2.2.0 release from being flashed onto the DPU and

b. the UEFI setting for the BlueField Mode being set to instead of a valid setting.

The following post contains the full procedure to update and un-brick a BF2 DPU:

It is tricky to interrupt the boot process. You have to keep trying and you will eventually get it.

Hi! Thanks a lot for your help. I think I do meet a different problem. When my workstation boots up, the Bluefield2 card can run normally for few minutes. And then it just disappears. I found some errors in the dmesg log. It shows my card is too hot.


The BF2-DPU is meant to be installed in a server or workstation chassis with sufficient forced airflow around the heat sink.

If you place a fan such that you ensure sufficient airflow across the fins, it should work.


1 Like

yes, thanks a lot, have already scheduled to move it to a server.