Install doca 2.0.2 ubuntu2204 on bluefield 2 failed

Hi, I follow the guide how to install bfb image in Bluefield 2.

I faced with a problem that the ubuntu installation did not start and ssh fell off. Did someone encounter this? Tried to use bfb-install several times, the result is the same

bfb-install --bfb --config bf.cfg -rshim rshim0
Pushing bfb + cfg
1.09 GiB 0:01:14 [16.5MiB/s] [ <=> ]
Collecting BlueField booting status. Press Ctrl+C to stop…
INFO[BL2]: start
INFO[BL2]: DDR POST passed
INFO[BL2]: UEFI loaded
INFO[BL31]: start
INFO[BL31]: lifecycle Production
INFO[BL31]: runtime
INFO[UEFI]: eMMC probed
INFO[UEFI]: PCIe enum start
INFO[UEFI]: PCIe enum end
INFO[UEFI]: exit Boot Service

Waiting couple hours did not help me.


Although the doca_1.5_ubuntu2004 version is installed successfully.
Can someone suggest how to debug such kind of issue?

Are you able to access the DPU console and gain access?
(It might give us a better idea of the current status of the DPU)
Was initially DOCA 1.5.1 successfully installed and you tried to push 2.0.2?
Are you able to successfully re-install 1.5.1?
Have you tried to disable secure boot, push 2.0.2 then re-enable secure boot?

1 Like

We have the same problem here. We just flashed the bfb image manually. DOCA 2.0.2 definitely has a problem on the install.

yes, I have, I use rshim in order to restore doca_1.5_ubuntu2004. I reinstall it from scratch and try to install doca2_ubuntu2204.bfb.

Have you tried to disable secure boot, push 2.0.2 then re-enable secure boot?
I will check, thanks.

Disabling secure boot helped to me. @spruitt thanks a lot.

Yavtuk - what OS & specific version are you running on your host machine?

Hi, Ubuntu 22.04

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.