JetPack 3.1 post-flash installation fails


I have a problem with JetPack 3.1 on Ubuntu 16.04: the installation of the software after flashing step does not go on.

My desktop PC can see and can ping the TX1, but Jetpack does not see it and the installation of OpenCV, MMAPI, TensorRT and VisionWorks fails.

I do not understand whats wrong because I have not log files and no errors are reported.
With previous Jetpacks I had no problems also installing them without flashing, simply inserting the IP address of the TX1.

Any ideas?

Thank you

Try single thread downloads:


Hi linuxdev,
I tried, but it freezes anyway.

The option is for “download” or for “upload to TX1”?

My problem is when Jetpack tries to connect to TX1 using local network to upload the post flash packages…

Ok, I faced the problem: OpenSSH on Ubuntu 16.04.

I tried with a PC with OpenSSH correctly installed and started to work, but asking me a lot of passwords using the strange new OpenSSH gui.

I use a Fedora host so I can’t comment on Ubuntu GUI apps, but generally speaking there is an ssh mechanism known as “askpass” (environment variable SSH_ASKPASS can name a program used for askpass). When you ssh into an account normally you only provide a password on command line and don’t need the askpass mechanism…but if the ssh is sending a command and that command needs a second password (such as for “sudo”), then ssh needs to ask for a second password…that is what askpass is for. It is quite possible you are seeing a GUI of the askpass mechanism when further passwords are being requested by ssh after a first password gets you in.

Normally if you log in as “ubuntu” the pass is “ubuntu”, and if you log in as “nvidia” pass is “nvidia”. You might need to enter that password a second time or more if sudo is running something. There may also be cases where you need to enter the password on your host PC for whatever account you are logged in as if installing or running software on your host via sudo.

More information on what passwords are being requested would help.

Do keep in mind that if your system is not protected behind a router (such as the router your WiFi connects to), then you are at high risk to have someone get in to any system using default install passwords (in other words, if you have a router in bridged mode the outside can get to you…but most routers are not bridged…a university dormitory or public WiFi would be an example of a high risk since many people are on the same LAN).

askpass… exactly.

On the laptop that I was using to update the TX1 it was not installed after the migration to Ubuntu 16.04.

I went into askpass the first time on the Jetson TX1 trying to update a GIT repository using QtCreator after the migration to Ubuntu 16.04. Without askpass it was not possible.
The same is for Jetpack 3.1 and Ubuntu 16.04, without askpass “simple” username and password inserted in the Jetpack GUI is not enough.

To be more precise I connected the TX1 to the laptop with a direct ethernet wired connection and I used the Wifi on the Laptop to get connected to the Internet.