JetPack 3.2 Installation on TX2 stops

Hi,
I just flashed the TX2 with JetPack 3.2 and it went well. The Jetson boots and it connects to the internet.
However, during the installation of the packages from the host it stops here:

ubuntu@128.232.86.9's password:
Copying /local/scratch/am2266/jetson3.2/jetpack_download/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb file to target...
ubuntu@128.232.86.9's password:
cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb
    602,560,414 100%  265.29MB/s    0:00:02 (xfr#1, to-chk=0/1)

sent 98,326 bytes  received 171,900 bytes  18,636.28 bytes/sec
total size is 602,560,414  speedup is 2,229.84

I tried also using the nvidia user and the same happens.
Any idea of what is going on?

Hi am2266, does the freeze always occur at the same place, or does it occur randomly during the transfer?

Are you using the Jetson’s WiFi? JetPack setup requires a wired ethernet connection. If you already have ethernet connection via a switch/router, you may want to try directly connecting NIC port of your host PC and Jetson. Perhaps these techniques will make a more stable connection for you.

It always stops at the same place.
I am using the Jetson wifi to connect to the same router as the host. I will try with ethernet.
Thanks.

I tried to connect the Jetson and the host to the same switch using ethernet cables and the installation stops at the same point.

I noticed that the first step creates the folder cuda-l4t in the home of the TX2 with the following files inside:
-rwx------ 1 nvidia nvidia 1199 Dec 12 17:59 cuda-l4t.sh*
-rw-r–r-- 1 nvidia nvidia 602560414 Dec 12 17:59 cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb

For some reason it doesn’t start the installation.

It freezes for me as well. See:
https://devtalk.nvidia.com/default/topic/1027302/announcements/jetpack-3-2-mdash-l4t-r28-2-developer-preview-for-jetson-tx2/post/5225869/#5225869

I believe it is a bug in the package selection.

I have the same problem also when installing the JetPack 3.1 from an Ubuntu 14.04.
This is becoming quite annoying.
Is there a way to install everything directly on the Jetson?

The bug I mention is only in the JetPack3.2 preview release…it works on JetPack3.1. Note that this relies on the Jetson itself being connected only with wired ethernet. WiFi on the Jetson side will cause failure. It is ok if your host PC uses WiFi to the internet. Note that if your router or firewalling gets in the way this too will cause a similar issue.

The packages are not generally available for separate download, but you can do this. During a flash where packages are selected you will find file “repository.json”. Within this are listings of URLs associated with different packages. You can use wget to download those “.deb” files…just be sure you get the arm64 version. The order of install will be important, I think the order the packages are listed in within JetPack satisfies that order (otherwise it is trial and error).