Jetpack 4.2.1 TX2 Dev Kit use SSD as boot drive

Hi All,

I previously had a sata ssd acting as my boot drive. I’m sure I used a JetsonHacks method to copy emmc files to the SSD then alter a boot file. Either I can’t find the method or something has changed.

I have also tried flashing the L4T (latest) img to the SSD but can’t find a boot file to edit to point out the new root location at /dev/sda1

Any thoughts would be greatly appreciated!

Thanks
Ben

Hi bj-neilson,

Please refer Topic-1060950 steps to flash on external devices.

Thanks very much @carolyuu

Hi @carolyuu,

I carried out the steps as per Topic-1060950.

I now have the system running on an SSD. It seems to have flashed only a very basic setup. I cannot find a CUDA installation for example.

Almost there!

Thanks
Ben

Hi bj-neilson,

Good to know :)
You can use sdkmanager to install sdk components (include CUDA, CUDNN, MMAPI…).

Thanks for the quick reply @carolyu :)

I had set all components to install when running SDK Manager on the host. That generated a system.img and system.img.raw file, as well as flashing the eMMC on the TX2 as would be normal.

Once I had prepared the SDD as per your instructions I executed:

sudo ./flash.sh jetson-tx2 external

Should that command be more like:

sudo ./flash.sh -r -k APP jetson-tx2 external, as you’d use for flashing a previously cloned image?

Or, am I missing something completely…can I install SDK Manager on the TX2 now that the OS is running on my SATA drive and install the extra components directly?

Thanks for your patience…I’m learning slowly!

Ben

I’ve tried again several times.

I flashed the eMMC as per normal with SDK Manager. I then cloned the eMMC using:

sudo ./flash.sh -r -k APP -G backup.img jetson-tx2 mmcblk0p1, then

sudo cp backup.img.raw bootloader/system.img, then

sudo ./flash.sh -r -k APP jetson-tx2 external and sudo ./flash.sh jetson-tx2 external.

Still can’t get any more than the basic OS on the SSD. Most importantly no CUDA.

Any thoughts? Can I install SDK Manager on the TX2 to install the missing components?

Thanks
Ben

Hi bj-neilson.

For #4, you can run on SSD success right?
After you flash image on SSD, you can use sdkmanager to install SDK components.
Please unselect “Jetson OS” and select “Jetson SDK Components” in sdkmanager steps 2.

Hi @caroluu

Thanks for the continued help! I did as suggested. Once the TX2 was booting from the SSD I was them able to run SDK Manager, de-select flash OS, and install the other components.

Something is still wrong though.

I’m having trouble building RTABMAP_ROS from source. Is related to libGL.so problem as per https://github.com/introlab/rtabmap_ros/issues/352

Searching around I found it was suggested those files were related to Nvidia graphics driver. I get:

ubuntu@tx2:~$ nvidia smi
bash: nvidia: command not found

ubuntu@tx2:~$ nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2019 NVIDIA Corporation
Built on Mon_Mar_11_22:13:24_CDT_2019
Cuda compilation tools, release 10.0, V10.0.326

I seem to be missing drivers and and think that CUDA installation may not be complete. SDK Manager reported all as being installed and ok. Any thoughts?

Thanks again,
Ben

Hi bj-neilson,

The “nvidia smi” command is using on Desktop, not on Jetson platform.
Please file a new topic about building RTABMAP_ROS issue. Thanks!

Thanks carolyuu, I’ll go back to 4.2 and try. Losing a bit much time at the moment with the new version. It’ll be good, just not yet, and I do t have enough Linux knowledge to work with it.