Jetpack 4.6.1 image for the Jetson Nano 2GB is corrupted

If you get the message “INSTALLATION FAILED: The installer encountered an unrecoverable error” when booting your Jetson Nano the first time, don’t bother googling for passwords, or trying the headless approach.

The firmware image for JetPack v4.6.1 is corrupted. It’s been corrupted since it was released and I doubt they’ll ever fix it. Get the v4.6.0 instead.

Hi gooocy,

Please download the latest SDK Manager and try again.

If still fail to install JetPack-4.6.1, please provide the logs from ~/.nvsdkm folder from your host ubuntu PC.

I’ve looked into this. It involves

  • take a security challenge to download the SDK Manager
  • try installing it, only to see it fail because the SDK Manager can’t be run on the Jetson (wtf)
  • boot up a desktop Linux OS
  • take another security challenge, download the SDK Manager again
  • take another, extra convoluted security challenge to log into the stupid web app
  • carry the Jetson board to the desktop PC, power it with an external power supply, connect it to the desktop over USB
  • realize that Fedora is softlocked from downloading anything, even though it runs the SDK Manager perfectly fine

…potentially more, because I gave up during that stage. It’s not worth the trouble for a 0.0.1 upgrade.


Please just fix the corrupt image.

The flash software has always run on a separate Ubuntu 18.04 host PC (JetPack 5.x+ for newer hardware uses Ubuntu 20.04). Embedded systems don’t have an actual BIOS. If they did, then they would be larger and consume more power and be more expensive. Without that BIOS, and by actually generating a build image rather than losing the ability to work with custom installs (although most people don’t use that), one really needs that second computer (the host PC). Thus, the flash software was always intended to run on that host PC and not the Jetson itself. It is truly inconvenient, but it has good reasons for being the way it is.

I too would like to change things about login, but it works for me, and the number of professional thieves targeting large corporation login credentials is just mind boggling (I’ve had to deal with this myself twice in about a year, and my parents as well). I’d love a chance to work on the actual JetPack software (it isn’t open source), though I don’t envy those who must work on SDK Manager (JetPack is the GUI front end, and it didn’t always have the network abilities it has now; those are from SDKM as a network tool on top of JetPack). Sadly, that same software is used for other hardware you’ve never heard of, and used by purely industrial applications in commercial settings, and so to get a uniform single-software install method it has complicated things for Jetsons. Even so, over time, I’ve watched this development since the Tegra 3 (well over a decade old), and it is an improvement over a lot of loose files and tar packages. It could evolve though for Jetsons without hurting its utility across the different hardware and uses.

I used Fedora for a long time. It wasn’t until some of the GUI frontend came along that Ubuntu started becoming important. The actual flash software (which is not GUI) allows a number of Linux systems to work, but for those working on that GUI part it would be a bit of a nightmare to keep up with multiple flavors/distributions of Linux. I too personally like Fedora more than Ubuntu, but surprisingly, find the LTS version of Ubuntu to be an improvement over CentOS so far as being “more modern”. This would seem to be a joke to say Ubuntu 18.04 or Ubuntu 20.04 LTS are “modern”, and they are not, but getting a newer CentOS is worse (one has to use the paid commercial RedHat to get something moving a bit faster for LTS in that genre). Fedora rocks, but supporting its fast changes takes more effort than any LTS distribution.

So far as a corrupt image goes, I’ve not known any of the releases to have this (and I’ve been looking at this in detail for over a decade). I have known many network issues which are not just an NVIDIA thing and not due to the download/install setup. Unfortunately, the downloads are quite large. It is just a matter of statistics and probability that more and larger downloads will find those weaknesses. The log files matter a lot here, and a detailed listing of what might be corrupt will provide actual knowledge if deleting what was downloaded and reinstalling it doesn’t work.

If there are issues with login, I promise you can post here and it actually gets looked at and fixed if it is from the NVIDIA side (and I’m not an NVIDIA employee, I just know some of the people who look at those issues). But you have to give it a try. Don’t give up.

Did you get the image from this page? I tried it the other day it works.
Getting Started With Jetson Nano Developer Kit | NVIDIA Developer

The link you provided is for Nano devkit, but your subject is for Nano 2GB devkit.
Are you using Nano 2GB devkit or Nano devkit?

For Nano 2GB, you should refer to Getting Started with Jetson Nano 2GB Developer Kit | NVIDIA Developer

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.