Jetpack 6 Wifi slow startup with backport-iwlwifi-dkms

I am using an AX210 wifi card and installing the backport-iwlwifi-dkms module since Jetpack 6 doesn’t include the driver by default. As recently as a month ago this would work immediately after installing and the wireless interface would come up right away at boot. Now the behavior is that it takes 73 seconds after boot before the wireless interface comes up.

jetson@jetson:~$ sudo dmesg | grep wifi
[   11.156443] Loading modules backported from iwlwifi
[   11.156449] iwlwifi-stack-public:master:9858:4c7cba27
[   11.369914] iwlwifi 0001:01:00.0: Adding to iommu group 3
[   11.370063] iwlwifi 0001:01:00.0: enabling device (0000 -> 0002)
[   72.674202] iwlwifi 0001:01:00.0: api flags index 2 larger than supported by driver
[   72.674263] iwlwifi 0001:01:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.0.2.36
[   72.682163] iwlwifi 0001:01:00.0: loaded firmware version 73.35c0a2c6.0 ty-a0-gf-a0-73.ucode op_mode iwlmvm
[   72.710207] iwlwifi 0001:01:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[   72.872834] iwlwifi 0001:01:00.0: loaded PNVM version e28bb9d7
[   72.884810] iwlwifi 0001:01:00.0: Detected RF GF, rfid=0x10d000
[   72.956391] iwlwifi 0001:01:00.0: base HW address: 4c:49:6c:f2:17:8c
[   76.638440] iwlwifi 0001:01:00.0: Got NSS = 4 - trimming to 2

There is also some error messages in the console when it does come up

jetson@jetson:~$ [   72.674750] iwlwifi 0001:01:00.0: api flags index 2 larger than supported by driver
[   72.700030] thermal thermal_zone9: failed to read out thermal zone (-61)
[   73.217204] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217220] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217223] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217226] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217228] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217230] ACPI: <n/a>: failed to evaluate _DSM (0x1001)
[   73.217233] ACPI: <n/a>: failed to evaluate _DSM (0x1001)

Hi,
Please confirm you use Orin Nano or Jetson Nano. The topic is in Jetson Nano category but it looks like you are using Orin Nano.

Orin Nano, my mistake I selected the wrong tag

Hi,
Are you able to re-flash the system and check if the issue is still present. Would like to see if the same issue occurs on a fresh system.

I’ve reflashed a bunch of times, the issue persists

@dakejahl I have encountered the same problem.
So, I installed Wi-Fi driver from source code.

At first, I download backports-5.15.81-1.tar.xz from https://backports.wiki.kernel.org/index.php/Releases.
I installed backports-iwlwifi from source code.

tar Jxfv backports-5.15.81-1.tar.xz
cd backports-5.15.81-1
make defconfig-iwlwifi
make -j8
sudo make install

I add the following line to /etc/modprobe.d/iwlwifi.conf.

options iwlwifi 11n_disable=1

And, I reboot OS.

sudo reboot
2 Likes

Does this result in any different behavior than simply installing the package via apt?

In my environment, I could avoid this problem.

It looks like this fixes the issue. I installed backports-5.15.148-1.tar.xz on Jetpack 6 5.15.136-tegra kernel.

I also added iwlwifi to
sudo nano /etc/initramfs-tools/modules
then ran sudo update-initramfs -u

jetson@jetson:~$ sudo dmesg | grep iw
[sudo] password for jetson:
[ 9.881819] iwlwifi 0001:01:00.0: Adding to iommu group 3
[ 9.881978] iwlwifi 0001:01:00.0: enabling device (0000 → 0002)
[ 9.887473] iwlwifi 0001:01:00.0: api flags index 2 larger than supported by driver
[ 9.887507] iwlwifi 0001:01:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.63.2.2
[ 9.887839] iwlwifi 0001:01:00.0: loaded firmware version 66.f1c864e0.0 ty-a0-gf-a0-66.ucode op_mode iwlmvm
[ 10.899519] iwlwifi 0001:01:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[ 11.117998] iwlwifi 0001:01:00.0: loaded PNVM version 0xe28bb9d7
[ 11.133989] iwlwifi 0001:01:00.0: Detected RF GF, rfid=0x10d000
[ 11.202388] iwlwifi 0001:01:00.0: base HW address: c8:15:4e:d2:a8:07

1 Like

I found another solution – building the kernel from source. I added these to the arch/arm64/configs/defconfig

CONFIG_WLAN=y
CONFIG_WLAN_VENDOR_INTEL=y
CONFIG_IWLWIFI=m
CONFIG_IWLWIFI_LEDS=y
CONFIG_IWLDVM=m
CONFIG_IWLMVM=m
CONFIG_IWLWIFI_OPMODE_MODULAR=y
1 Like